Support » Plugin: SI CAPTCHA Anti-Spam » [Plugin: SI CAPTCHA Anti-Spam] SI CAPTCHA browser status bar "Waiting for"

  • Hi Mike!

    I am relatively new to WordPress (installed three months ago) and just installed SI Captcha this weekend to cut down on the HUNDREDS of Blog Spam I have received (and had to trash). SI Captcha is the only plugin I have (from the default WordPress configuration). Akismet is not activate.

    While I am new to WordPress, I am not new to Linux nor running my own Linux servers (since 2002).

    Yesterday I blogged about how great SI CAPTCHA is :

    But I realized afterwards that adding a comment is really slow with “Waiting for” on the status bar for a long time.

    Having done some additional testing I think:
    1. If SI CAPTCHA is deactivated, then posting a comment is fast.
    2. If I am logged in, SI CAPTCHA is fast.
    3. It is only if I am not logged in, that the WAITING message appears for exactly ONE MINUTE, so I’m wondering if this might be some type of timeout issue?

    Also, I have a second question, if I don’t type in the Captcha and click to post the comment I correctly see a web page stating “Error: You did not enter a Captcha phrase. Press your browsers back button and try again.” If I “tail -f /var/log/httpd/access_log I see a “500” error each time, which normally would indicate an internal server error. I also know this because OSSEC generates an “Alert Level 5” when it sees a 500 error in the log. But I notice that even when SI CAPTCHA is deactivated and I try to “post comment” (but leave the comment blank) that I get a 500 error, so I think this 500 error is more related to the WordPress PHP than the SI CAPTCHA PHP?

    p.s. before posting I looked in the FAQ, and did not see anything that might answer these two questions.



Viewing 9 replies - 1 through 9 (of 9 total)
  • Not clear here… what was your question?

    Two questions:

    1. Should it take ONE MINUTE to post a comment with SI CAPTCHA turned on? (as contrasted with a couple seconds when inactive, i.e. this is not a server resource issue)

    2. Should leaving the CAPTCHA blank generate a 500 error in the Apache access log (“internal server error”)

    Thanks in advance,


    The answer to both questions is no.

    It is possible, permissions too high are the problem
    I see on your test page you have permission 0777 on one of the directories, on some servers this can cause a 500 error. Try 0755 to see if that fixes it.
    Directory /captcha-temp/ OK – Writable 0777

    Hi Mike,

    Thanks very much for the quick reply!

    I have just made a donation to your paypal.

    My problem with “WAITING FOR” was solved by chown from “root” to “apache”.

    I originally had 0755 but changed to 0777 because the “CAPTCHA PHP requirements test” told me:

    Directory /captcha-temp/ Directory Unwritable (fix permissions). Permissions are: 0755 Fixing this may require assigning 0755 permissions or higher (e.g. 0777 on some hosts. Try 0755 first, because 0777 is sometimes too much and will not work.) Fixing the actual problem is recommended, but you can uncheck this setting on the plugin options page: “Use CAPTCHA without PHP session” and the captcha will work this way just fine (as long as PHP sessions are working).

    –> You might consider adding a sentence to check the ownership of the files, must match the user that runs httpd — your codex link helped me understand that aspect.

    However, I still get 500 “internal server error” in Apache’s access_log if I click to post and have not filled in the Captcha. Here is a copy-and-paste from the beginning of the log entry:

    [10/Nov/2010:21:26:40] “POST /blog/wp-comments-post.php HTTP/1.1” 500 1236 “” “

    I’m not overly concerned about the 500, but did want to point it out to you, maybe you can see if reproducible on another system? My guess is the problem is more likely to be in the WordPress code than in the Captcha code.

    Many thanks again,


    Hey, can you explain in detail how did you solve the “WAITING FOR” problem?

    “My problem with “WAITING FOR” was solved by chown from “root” to “apache”.” – I did not understand this line.

    I’m asking because our site is also facing same problem(Waiting for or loading). Nothing comes out.


    Assuming you are running on Linux (not Windows)…

    It was suggested that changing the numeric file permissions to 0755 might solve this problem, but it was not the numbers, it was the name of the owner (in Linux) of the files.

    WordPress had been installed by the “root” user, but the files needed to be owned by apache (the web server software).

    chown is a Linux command to change who owns the file.

    If you are not familiar with the chown command, you should Google it.

    Hope that helps,


    Thanks for reply. It is lynux server. It is also running under apache server. By chown it to apache did not fix the problem.

    Basically, I’m not experienced with lynux system except the CRON and chmod command.

    So, only “root” and “apache” are the parameters for chown? Can It be anything else?

    Thanks again for your help.

    This command should tell you who “owns” the Apache (httpd) process in your Linux system:

    ps -ef | grep httpd

    Notice that the two commands are separated by a vertical bar (pipe) — the output of the first program is fed as input to the second program for further processing

    Also, when you run chown, you need to be in the appropriate directory, and specify the correct files and/or directories.

    Hope that helps,


    Oh Gaffer, thank you very much. Although your problem and my problem were same, but the reasons were different. My problem was not file owner permission, rather it was problem from theme. The theme developers implemented AJAX comment posting. Later, I removed the ajax request from comment form and it started working.

    File permission and theme, both of them are top reasons for why SI captcha plugin does not work.

    Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: SI CAPTCHA Anti-Spam] SI CAPTCHA browser status bar "Waiting for"’ is closed to new replies.