Settings: You do not have sufficient permissions to access this page (6 posts)

  1. Alfie_J
    Posted 4 years ago #

    Every time I try to access the Settings page for SI-Captcha I get the following message:

    You do not have sufficient permissions to access this page.

    I've spent ages looking at other support posts regarding this error but none of them seem to have a definitive fix. So far it's just the SI-Captcha plugin that's giving me the error.

    NB I have multi-site enabled.

    Help please!


  2. lilyana
    Posted 4 years ago #

    I have the same problem as Alfie.

    I have multi-site enabled.
    I followed the installation instructions for installing on multi-site. Installed in the mu-plugins folder. Moved the "Si-captcha.php" file to the mu-plugins folder.

    Steps I took at my WP Admin interface:
    "Network Admin-Plugins-Must Use menu" then "SI Captcha ... Settings" link.
    I get the "You do not have sufficient permissions to access this page."

    Please help, mike!

  3. Mike Challis
    Plugin Author

    Posted 4 years ago #

    I am not real up to date on multi-site. I do not have multi-site to test with.
    Perhaps you could ask for help from the multi-site forum.

    Maybe ask other users if they have it working or not. I do not know what could be causing it. If it is figured out I can update it. I just have no idea what the problem might be.

  4. pzYsTorM
    Posted 4 years ago #

    I have the same issue :(
    But I have debugged the issue:

    The problem is:
    ./wp-admin/includes/plugin.php (Line 1533 in WordPress 3.3.2)

    if ( isset( $plugin_page ) ) {
    if ( isset( $_wp_submenu_nopriv[$parent][$plugin_page] ) )
    return false;

    $hookname = get_plugin_page_hookname($plugin_page, $parent);

    if ( !isset($_registered_pages[$hookname]) )
    return false;

    The second return returns false. I dont know... whats this _registered_pages? Why doesnt it contain the hookname (plugins_page_si-captcha-for-wordpress/si-captcha)?

    I have tried to comment out these two lines... then the menu gets displayed. But the page itself does not :(

  5. dharmen99
    Posted 4 years ago #

    I also have the same problem (currently using WP 3.12 multi site and SI CAPTCHA Anti-Spam 2.7.5). Its not clear to me whether the above post is offering a solution or not?

  6. bobp
    Posted 4 years ago #

    I'm having the same issue with the same error message when I click on "settings" for the plugin
    "You do not have sufficient permissions to access this page"

    I have a multi-site setup.

    The installation instructions indicate to install in /mu-plusins/, I assume in the Plugins folder.... I have no such folder... does it have
    to be created or are those instructions likely specifically for WPMU

    Has anyone come been able to succesfully install and use on a Multi-Site?

    thanks for any help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SI CAPTCHA Anti-Spam
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic