WordPress.org

Forums

SI CAPTCHA Anti-Spam
Captcha showing on Facebook posting links (6 posts)

  1. Adwiz
    Member
    Posted 5 years ago #

    I just discovered that SI Captcha 2.5.3 is putting the Captcha image in place of the page images when trying to post a WordPress blog posting or page on Facebook. Worse, it's the only image you can choose for the thumbnail! It looks like this when using the Facebook Sharer PHP module:

    Image link

    I'll have to turn it off until a fix can be developed, as this seriously inhibits people sharing my WP postings.

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 5 years ago #

    What is Facebook Sharer PHP module?
    Do you have a URL to it?
    Also a URL to your page with the problem will be helpful.

  3. xiexiema
    Member
    Posted 4 years ago #

    I too am having this problem. Especially on pages where there are no images for Facebook to pick up.

    I have searched for a way to stop FB looking at a certain image but it is way too complex for me.

    Having to disable this great plugin and use a text based one instead.

    For the developer this may help:

    https://developers.facebook.com/tools/lint/

    Put a URL in there and if the page or post contains no other images than the Captcha Facebook will use the Captcha image.

  4. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    Will anybody post a page on their WordPress site that is having this problem?

  5. xiexiema
    Member
    Posted 4 years ago #

    Hi Mike,

    Thanks for your fast response, nice one.

    Sorry it's not of great help. I tried to explain above what is the cause of this. Personally I have to disable for the time being hence I cannot post a link.

    I think the basic facts are that - Facebook's Like Button will scan your page for the first available image. Of course - if you have a post with no images - the first image that will appear is the Captcha.

    So we need to find a way to:

    1. Force facebook NOT to use the Captcha image (on a normal page)
    2. Force facebook to use a default image (on a page with no images)

    There is a plug in that solves problem 2. But it only seems to work if the Captcha is not on that page.

    I hope that helps but sorry I can't post a link as I have had to disable for the time being.

    The FB Lint tool may help you trace it as you can enter any URL there and it will show you what image FB will use.

    Cheers

  6. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    None of my WP sites have this problem. That is why I need a URL to a page that has the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SI CAPTCHA Anti-Spam
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic