WordPress.org

Support

Support » Plugins and Hacks » [Plugin: SI CAPTCHA Anti-Spam] captcha not appearing at all

[Plugin: SI CAPTCHA Anti-Spam] captcha not appearing at all

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Mike Challis

    @mikechallis

    > I am guessing it is because the theme uses a custom sign-up page?
    yes

    Try adding the same do_action and apply_filters the original registration page had. If that does not work I can’t help you because you have modified the WP files.

    do_action('register_form');

    $errors = apply_filters( 'registration_errors', $errors, $user_login, $user_email );

    I can’t see the captcha at all either. http://www.planxdesign.eu/2010/02/22/logo-florecer/#comments

    Plugin Author Mike Challis

    @mikechallis

    crs1138,

    What version is your WordPress?

    It could be a theme causing it…
    Do this as a test:
    Activate the SI CAPTCHA plugin and change your theme to
    the “WordPress Default” theme.
    Log out of Admin and test the captcha as a normal user.
    Does the captcha work properly now?
    If it does then the theme you are using is the cause.

    When diagnosing missing CAPTCHA field on comment form….
    The version of WP makes a difference…

    (WP 2 series) Your theme must have a
    <?php do_action('comment_form', $post->ID); ?> tag inside your comments.php form. Most themes do. The
    best place to locate the tag is before the comment textarea, you may
    want to move it if it is below the comment textarea.

    (WP 3 series with a proper WP3 theme does not need this step, but if you have WP3 update to plugin version 2.5.2 or higher, if you still have the missing captcha, try above WP Series 2 steps)

    See here:
    http://wordpress.org/support/topic/392558?replies=3

    Thank you for your prompt response. Sorry for not complete info. I’m running WP3.0.1 with an adapted theme from earlier WP version.

    Ok, it is the theme, what causes the problem, but CAPTCHA won’t appear even when I added the recommended line of code into my comments.php. Any ideas what to do next?

    Also is there any way, how to get the CAPTCHA to work with forms on the page? These are actually, where the most of the spam comes from.

    Sorry my mistake, I was checking it while logged in as admin. It works just fine. Thanks again.

    Still I’d be interested if there is any way, how to get the CAPTCHA to work with forms on the page? These are actually, where the most of the spam comes from. I’m using a plugin Contact Form 7 v2.4.1 to generate the plugins.

    Plugin Author Mike Challis

    @mikechallis

    This is the form you need: (I made this one)

    Fast Secure Contact Form
    http://wordpress.org/extend/plugins/si-contact-form/

    My Gift To You

    Thanks Mike, but my form has bit more fields, it’s kind of a survey, rather than just a contact form.

    Plugin Author Mike Challis

    @mikechallis

    Then you need to make your own custom integration.
    here is s free library
    http://www.phpcaptcha.org/

    I’m sorry, but the same 🙁

    WP version 3.0.1
    PHP version 5.0

    After activating plugin there is the picture:

    http://img823.imageshack.us/img823/745/captchac.jpg

    Could you help, please?

    Plugin Author Mike Challis

    @mikechallis

    Aines,
    I need URL to site to help you. It could be a permission problem, PHP problem, or Site URL problem.

    No problem. Here it is: http://jinnbaskoff.com/contacts

    Plugin Author Mike Challis

    @mikechallis

    Aines,

    That site does not come up, is the URL correct?

    Mike Challis, yep, everything’s ok. Link is correct and I can visit it.

    Plugin Author Mike Challis

    @mikechallis

    Look in your PHP error log, tell me what you find?

    [Mon Oct 18 01:13:42 2010] [notice] Accept mutex: flock (Default: flock)
    [Mon Oct 18 01:14:01 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Mon Oct 18 01:14:01 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Mon Oct 18 01:14:01 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Mon Oct 18 01:14:01 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Mon Oct 18 01:14:01 2010] [notice] Accept mutex: flock (Default: flock)
    [Tue Oct 19 00:01:29 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Tue Oct 19 00:01:31 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Tue Oct 19 00:01:31 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Tue Oct 19 00:01:31 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Tue Oct 19 00:01:31 2010] [notice] Accept mutex: flock (Default: flock)
    [Wed Oct 20 00:01:38 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Wed Oct 20 00:01:45 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Oct 20 00:01:45 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Wed Oct 20 00:01:46 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Wed Oct 20 00:01:46 2010] [notice] Accept mutex: flock (Default: flock)
    [Thu Oct 21 00:01:40 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Thu Oct 21 00:01:42 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Thu Oct 21 00:01:43 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Thu Oct 21 00:01:43 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Thu Oct 21 00:01:43 2010] [notice] Accept mutex: flock (Default: flock)
Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: SI CAPTCHA Anti-Spam] captcha not appearing at all’ is closed to new replies.