[Plugin: SI CAPTCHA Anti-Spam] CAPTCHA image (text not image) (20 posts)

  1. podictionary
    Posted 6 years ago #

    Hi Mike
    Using WPMU and BuddyPress 1.1.2 with default theme
    FTP into mu-plugins, moved php
    Set for only registration page.
    Shows up but only some text saying "CAPTCHA image" but does not show any image.


  2. Mike Challis
    Posted 6 years ago #

    to help I need a URL

  3. KarlEngstrom
    Posted 6 years ago #

    Hi Mike-

    I'm getting the same results as podictionary. It was working up through 2.0.4 but died with 2.2.1.
    Demo URL is: http://www.ampsite.com/wp2

    I currently have all other plugins deactivated. Freetype isn't on but it was working OK with GD.

    Any sugestions?


  4. Mike Challis
    Posted 6 years ago #


    Your PHP does not have freetype support. That is a problem it can normally workaround by detecting that and using GD fonts instead. It looks like that part is broke in this version. I am working on a fix. maybe tonight, if not then tomorrow.


  5. Mike Challis
    Posted 6 years ago #

    Karl, fixed it!

    = 2.2.2 =
    - (23 Nov 2009) - Added 5 random CAPTCHA fonts
    - Fixed fail over to GD Fonts on the CAPTCHA when TTF Fonts are not enabled in PHP (it was broken)

    PS the fonts will not look as good, the catptcha is weaker when you do not have TTF fonts enabled because they do not have the warpage.

  6. Mike Challis
    Posted 6 years ago #

    Please update again, 2.2.2 was broke

    = 2.2.3 =
    - (23 Nov 2009) - Fix completely broke CAPTCHA, sorry about that

  7. stealthfiction
    Posted 6 years ago #

    Hi Mike. I downloaded the latest, installed in mu, moved the main file so I got global control.

    All checks pass. Folders were 775. (Also tried 777)

    Still not getting the image to show up.

    Can be seen at http://stealthfiction.com/pre-launch-status/

    Any ideas?

  8. podictionary
    Posted 6 years ago #

    Thanks Mike
    Sorry to be away for a week. Upgraded to your 2.2.3 but still no joy.

    Since http://www.guidegatineau.ca is a production site I've pulled the plugin for the moment.

    I did take an image of the not-working page though, plus the source code for same and have them zipped here if you care to look.

  9. Mike Challis
    Posted 6 years ago #

    when the image does not show up, view the source and see if the path is wrong. If it is please give me an example of how it is wrong.

  10. Mike Challis
    Posted 6 years ago #

    I have the flu so I could be be offline for 24 hours. Will work on this when I feel better.

  11. Mike Challis
    Posted 6 years ago #


    I see internal server error even with the readme.txt so if you still have the folders CHMOD to 777 that may be too high, put back to 755.


    then see if this test works:

    if it does not work after you do that look at the PHP error logs.

  12. stealthfiction
    Posted 6 years ago #


    That is the path I am getting for the image that isn't showing up.

    Everything is working now. I made the mistake of setting the folders to 775 instead of 755. Once I fixed that the problem went away. So if anyone is having that issue, double check the permissions.

    Thank you Mike for your support and for this great plugin.

  13. podictionary
    Posted 6 years ago #

    Thanks Mike
    Hope your flu is passing/passed

    path looks right but what do I know...

    I see the securimage_show.php at that location, I also see the ...mu-plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php is in place but when I try the test it tells me page not found.

  14. Mike Challis
    Posted 6 years ago #


    I am all better, thanks. It was just a 24 hour flu.

    I think you have a permalinks or permission problem.
    I see internal server error even with the readme.txt
    Check the CHMOD on the folders, maybe set to 755

    Posted 6 years ago #

    While setting up SI CAPTCHA plugin. I accidently enable the captcha on my login.php form, now I cannot log in because I cannot view the captcha image on my log in screen. Need help!

  16. Mike Challis
    Posted 6 years ago #


    FTP into your blog directory, then delete the si-captcha-for-wordpress folder in the plugins folder. Then the plugin will be disabled and you can log in.

  17. Alex
    Posted 6 years ago #

    Same problem here like podictionary. I think we have a permalinks problem. Just not sure if it's with the same AllowOverride issue that plagues some of us with images in the blogs.dir folders.

  18. Mike Challis
    Posted 6 years ago #

    All request for help should include a URL to the page with the problem, thanks.

  19. Freelancealot
    Posted 5 years ago #

    Hi Mike,

    I'm using Si Captcha successfully on one WordPress site already, but having difficulty implementing it on my own blog.

    The wordpress framework is in a different directory to the one that shows publically at http://www.freelancealot.co.uk/Herald/ so I'm guessing it's a permalink problem as the entry field for the captcha is appearing.

    Here's the code that appears on the page when you view a post (http://www.freelancealot.co.uk/Herald/2010/09/freelancealot-adopts-freelance-from-communication-charity/) with comments open:

    <a href="#" rel="nofollow" title="Refresh Image" onclick="si_captcha_refresh('si_image_com','com','','','http://www.freelancealot.co.uk/round_table/wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/securimage_show.php?no_trans=1&si_form_id=com&prefix='); return false;">

    Any ideas what I can do to fix it?

    Help appreciated.



  20. Mike Challis
    Posted 5 years ago #


    Check the WP settings in Admin - Settings - General
    WordPress address (URL)
    Blog address (URL)

    If one of these is incorrect you get that problem

Topic Closed

This topic has been closed to new replies.

About this Topic