WordPress.org

Support

Support » Plugins and Hacks » [Plugin: SI CAPTCHA Anti-Spam] Captcha image overlapping submit comment button

[Plugin: SI CAPTCHA Anti-Spam] Captcha image overlapping submit comment button

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mike Challis

    @mikechallis

    Your theme is causing that. You have WP version 3.0.1?

    WP 3.0 compliant themes do not need the <?php do_action (‘comment_form’, $post->ID);?> code in it because WP 3.0 has a new comments function separate from the comments.php template. SI CAPTCHA Anti-Spam version 2.5.2 or higher is fully WP 3.0 compliant.

    Be aware that using other themes (besides Twenty Ten) on WP 3.0 that are not fully WP 3.0 compliant can cause problems like this.

    Here is how to fix it:
    Look for wp-content/themes/default/comments.php
    If you are not using the default theme, look in the theme folder other than “default”.
    edit the comments.php
    Remove the <?php do_action (‘comment_form’, $post->ID);?> code in it
    WP 3.0+ does not need it.

    Did that fix it?

    Mike

    Hi Mike,

    I’m having exactly the same problem – here’s my versions:

    WP 3.0.1
    Atahualpa 3.5.3 (WP 3 compatible)
    SI Captcha 2.6.2

    I’ve had a look at the themes default comments.php and it does still have the line you referred to in it. If I remove that line, the captcha disappears completely (but the comment form still appears as normal). Am I missing something in the fix?

    Thanks,

    David.

    Plugin Author Mike Challis

    @mikechallis

    It could be the theme you are using is causing it…
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the “WordPress Default” theme.
    Does it work properly now?
    If it does then the theme you are using is the cause.

    Let me know what you find.

    Hmm – sorry, I’ve done lots of tweaking on the various sites I manage, and I’m afraid I can’t remember which one was causing the problem. I’ve done various updates (including reinstalling the theme on one of the sites), and now use the following snippet in the form, which works fine for me:

    <p> [captchac captcha-xxx]
    Please enter this code below:<br />
    [captchar captcha-xxx] </p>

    Obviously it doesn’t put the image next to the submit button, but it looks better this way round to me anyway.

    Cheers,

    Dave.

    Hello,

    First of all thank you Mike Challis for writing this plugin.

    I had a related problem. My captcha image was getting cropped at the bottom, making it unusable. This was a problem in IE7.

    The secure image measures 175px x 60px, but the div that contains it is hard-coded in the plugin to have a height of 40px.

    The solution was to make a small edit to line 491 of the si-captcha.php file. Change “height:40px” to “height:60px” and it will display properly in IE7.

    Mike if I may suggest a small mod, you could give your html elements ids and classes. You could also remove the height value altogether, or perhaps set it to height:auto.

    Hope this helps somebody else!

    Best regards

    Barry

    Plugin Author Mike Challis

    @mikechallis

    itsbarry,

    I have made improvements in the latest version. I think i fixed the problems reported here. Also these two new settings
    CSS style for Small CAPTCHA Image DIV:
    CSS style for Large CAPTCHA Image DIV:

    = 2.6.4 =
    – (19 Jan 2011) – Added more settings for setting CAPTCHA input field and label CAPTCHA input field CSS. These settings can be used to adjust the CAPTCHA input field to match your theme.
    See FAQ Page
    http://www.fastsecurecontactform.com/si-captcha-comment-form-css
    – Added new setting: “CAPTCHA input label position on the comment form:” Changes position of the CAPTCHA input labels on the comment form. Some themes have different label positions on the comment form.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: SI CAPTCHA Anti-Spam] Captcha image overlapping submit comment button’ is closed to new replies.