WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Shortcodes Pro] The buttons are not displayed in the TinyEditor menu

[Resolved] [Plugin: Shortcodes Pro] The buttons are not displayed in the TinyEditor menu

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Matt

    @sksmatt

    Hi Kerfred,

    Have you checked the Enable Rich Editor option?

    http://lab.mattvarone.com/plugins/shortcodes-pro/docs/lessons/Rich_Editor_Buttons.html

    Kind Regards!

    Yes, of course I checked it.

    I just discovered a new clue. The problem that I described does not happen on an English site. It happens on a French WordPress site with WPLANG = ‘fr_FR’ (in wp_config.php).

    But another question, when I run the plugin on an English site, and when I click on the rich editor button I created, it prints:
    [do action=”pub”/]
    whereas I want it to print [pub].
    May be this plugin is not expected to do what I want.

    Best regards.

    Plugin Author Matt

    @sksmatt

    Hi Kerfred,

    Please update to latest version 1.1.0.1, it fixes the issue with alternative languages.

    As for the output, the plugin bundles all shortcodes inside the “do” shortcode:
    [do action=”pub”/]
    [do action=”my-other-shortcode”/]

    Kind Regards!

    Thanks for your quick update.
    I updated to 1.1.0.1 but it doesn’t fix the issue.
    The shortcode buttons are not displayed in the sorting screen nor in the TinyEditor menu.

    Hi sksmatt,

    I have the same problem too me, after the update v1.1.1 in today. The shortcode buttons are not displayed in post/page editor. And also fatal error in Shortcodes Pro Setting page ;

    Call to undefined function shortcodes_pro_do_checkbox() in ...../wp-content/plugins/shortcodes-pro/inc/shortcodespro-options.php on line 459.
    Good Day!

    It works for me now with 1.1.1.
    Thank you very much.

    Plugin Author Matt

    @sksmatt

    Hi guys,

    Thanks for the feedback. UnderlineWords, please update to 1.1.1.1. If the buttons are not appearing try re-sorting them on the Sort Shortcodes page to clear the stored cache.

    Kind Regards!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Shortcodes Pro] The buttons are not displayed in the TinyEditor menu’ is closed to new replies.