Support » Plugins and Hacks » [Plugin: Shashin] Error message with widgets

[Plugin: Shashin] Error message with widgets

  • Hi

    Im using WP 2.7 and Shashin 2.3.5

    I get a error message with some of the widgets
    Like the “random images”

    Warning: Invalid argument supplied for foreach() in xx/xx/xx/wp-content/plugins/shashin/ShashinWidget.php on line 108

    Any idea of how i can fix this?

Viewing 15 replies - 1 through 15 (of 29 total)
  • Hi – that foreach statement is looping over a list of your albums. Have you added any of your Picasa albums to Shashin? Follow the Shashin link under your Tools menu – that’s where you can load your Picasa albums into Shashin.


    I am using WP 2.7.1 and Shashin 2.4.1

    None of the widgets are working for me. The codes are ok on pages but I got this error message in the place of widgets.

    Shashin Error: unable to retrieve albums.

    When adding the code suggested directly to sidebar.php, I got this:

    Fatal error: Call to undefined method Shashin::getalbumlist()

    Am I doing anything wrong?

    Hi – I’m not sure why the widgets aren’t working for you. Is it all of them or just some of them? I have tested them with WP 2.7.1 and WP 2.8. Could you let me know which widget you tried, and what settings you used?

    It looks like I accidently removed the getalbumlist() wrapper function in the latest version of Shashin. I will add it back and upload a fixed version.

    Mike T

    Hi, thanks for the reply. Single Image, Image Thumbnails seems ok, Random, Newest, Albums Thumbs are broken.
    Looking forward for the fixed version.

    Hi – I just uploaded Shashin 2.4.2 to wordpress.org – the Shashin::getAlbumList() function should work for you now. But I don’t know why some of the widgets aren’t working for you – I’m not aware of a problem with them. I’d like to see a screenshot of your widget admin page, so I can see exactly how you’re using them and then try to reproduce it. Can you upload a screenshot somewhere I can see it?

    Afternoon! Thanks for upgrading this and getting it ready for 2.8

    After Installing and attempting to add Albums, I get this error
    ShashinAlbum::setUserAlbums - Failed to insert database record for album ID 2147483647. Possible SQL Error:

    Hi again, sorry for the double post, I also just tried to target a specific album in the Tools menu and I get this error
    ShashinAlbum::setAlbum - Failed to insert/update database record for album. SQL Error:

    I’ll try to uninstall and reinstall and see if that works. Thanks for the great plugin though! I’ve been looking for a good one to post my albums!

    Hi – let’s take a look at the database insert query that’s failing. If you don’t mind a little code editing, please go to line 251 in ToppaWPFunctions.php (in your shashin plugin folder). Add this line immediately before the “return” line:


    Then try to add just one album again. It should then spew a SQL statement to your screen. Please copy and paste it here so I can take a look.

    Sorry for the late response.. Here it is:

    string(516) "insert into wp_shashin_album (album_id,user,name,link_url,title,description,location,cover_photo_url,photo_count,pub_date,geo_pos,include_in_random,last_updated) values (5347326438288378193,'TravelingWebGuy','HikeBehindMyApartments','http://picasaweb.google.com/TravelingWebGuy/HikeBehindMyApartments','Hike Behind my Apartments','','Tierrasanta California','http://lh4.ggpht.com/_CWScU39hW10/SjWFEHQ7yVE/AAAAAAAAAO8/TP26rilBWBo/s160-c/HikeBehindMyApartments.jpg',29,1244962800,'32.82917 -117.10278','Y',1245703401);"

    I tested your SQL statement, and it worked fine for me, so it’s not a syntax problem. Let’s see if we can get a message from your database as to why it’s failing for you. Please go to line 251 again in ToppaWPFunctions.php and remove the lines you added before. Then make it look like this:

    // return $wpdb->query($sql);

    So you’re commenting out the “return” line that’s there, and then adding 3 lines that should tell us why the database insert is failing. Then try to add the album again, and copy-and-paste the output here.

    Thanks, I added new the code in and this is what is returned:

    Hey dude, I just figured it out.. I have MySQL 4.0 on the server. Going to update to 5 and import the other tables.

    Sorry for not checking that first man!

    Cheers for all the help!

    Upgraded and now it works exactly how it should! w00t!

    Thanks again!

    I’m glad you got it working. Your mySQL version should have been the first thing I asked; sorry for not thinking of it. For anyone else following this, Shashin requires mySQL 4.1 or higher, as listed on my Shashin page.

    I tried to add an individual album and I am getting the same error reported above. However I am using the correct version of mySQL.

    ShashinAlbum::setAlbumPhotos – Failed to insert record for photo ID 2147483647. SQL Error:


    Any help would be appreciated.


Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: Shashin] Error message with widgets’ is closed to new replies.
Skip to toolbar