Support » Plugin: Share Post » [Plugin: Share Post] Fatal Error With Update 4-16-11

  • epaul13

    (@epaul13)


    Just auto installed the plugin update, got this error:

    Parse error: syntax error, unexpected T_STRING in /home/xxxx/public_html/xxxx.com/wp-content/plugins/share-post/share-post-admin.php on line 61

    What do I do? It obviously doesn’t work.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    (@esmi)

    Forum Moderator

    FTP into your site (or use whatever file management application your host provides) and delete the wp-content/plugins/share-post folder.

    epaul13

    (@epaul13)

    Yes thank you but its not crashing my site it just won’t reactivate. I’ve uninstalled/deleted/reinstalled and still get the same error. Any suggestions?

    janustudios

    (@jojithedevil)

    Does’nt works… BROKEN for all WPMU 3.1.1 proved… I was working fine but just a minute ago i updated and the plugin is broken.. is there any place we can download the back version~!

    janustudios

    (@jojithedevil)

    Herez the solution

    I just Updated to version 2.1.3 – Got this error – Parse error: syntax error, unexpected T_STRING in /var/www/wp-content/plugins/share-post/share-post-admin.php on line 61.

    Checking the file out reveals a missing “;” at the end of line 60.

    Just place a “;” at the end n tada!!! there u get a fix…

    Used the update feature in WP to update, so this may possibly affect others who have updated this way as well. Hope this helps anyone with this issue!

    epaul13

    (@epaul13)

    You’re a genius! Thanks!

    faithchad

    (@faithchad)

    Where is the line 60?

    I saw this answer in the Support page of Share Post but it does not tell us where is line 60. Can someone guide us?

    Plugin Author linksku

    (@linksku)

    I am very sorry about this. I released 2.1.3 in a rush and I wasn’t able to test it properly.

    2.1.3.5 fixes this error. If you are unable to access your admin panel, please open “root/wp-content/plugins/share-post/share-post-admin.php” and find “add_option( ‘sharepost_cloak’, 1 )”. Add a semi-colon to the end of that line to make it “add_option( ‘sharepost_cloak’, 1 );”. It will now work.

    I apologize for any trouble this has caused. I can guarantee that this will never happen again.

    candreu

    (@candreu)

    Now I have a problem with version 2.1.3.5. When I update, I get a fatal error with share-functions.php because it redeclares is_bot().

    Plugin Author linksku

    (@linksku)

    I will fix it in 2.1.4 first thing tomorrow. It is getting late today.

    For now, you can remove the is_bot() function from wp-content/plugins/share-post/functions.php or you can delete the plugin for now. Sorry for the inconvenience.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Share Post] Fatal Error With Update 4-16-11’ is closed to new replies.