Support » Plugin: Share Post » [Plugin: Share Post] Can't activate plugin

  • Resolved SchneiderBee


    When I attempt to activate this plugin, the screen goes white and this line of text appears:

    Fatal error: Call to undefined function: register_setting() in /web/wordpress/wp-content/plugins/share-post/share-post.php on line 45

    Too bad, too, because this would be perfect for my company’s blog.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author linksku


    I added backwards compatibility for 2.6.5, it should work now. Please let me know if it works properly or not, I don’t have 2.6.5 to test with.

    I installed version 1.2.1 of this plugin with WP 3.03. Only the Facebook share information is showing up. Any idea why?

    The DIGG part doesn’t show up at all and the Twitter part just shows the text “Tweet” that links to

    I would really like to use this plugin if I can get it to work.

    Plugin Author linksku


    That sounds like you don’t have Javascript enabled. Try enabling Javascript and try again.

    If it still doesn’t work, give me your website’s URL and I’ll try finding the problem.

    Thanks for trying to fix this. I do have Javascript enabled. I’m using Firefox on a Mac, but it’s not working on a PC in IE either.

    You can see what’s happening at the bottom of this post:


    Thanks for responding so fast, it works perfectly.

    Plugin Author linksku


    @schneiderbee: No problem, glad to hear it works 🙂
    Don’t forget 5 stars for the plugin 🙂

    $dangrgal: I think the problem lies in the “Ninja Gal” theme that you are using. It does not seem to have a footer. Check the files for “Ninja Gal” and see if you can find do_action('wp_footer').
    If not, I suggest you switch to a different theme, because all themes should have do_action('wp_footer').

    I you don’t want to switch, see if your theme has do_action('wp_header') or any other do_action() and I’ll see what I can do.

    Good luck 🙂

    @linksku: Thank you so much for taking a look at my problem.

    I added a footer to my theme and also added <?php wp_footer(); ?> to my footer.php and it seems to be working now.

    The only remaining issue I have is that there’s a background color on the Facebook part of the horizontal layout:

    Since my site has a dark background, I tried changing it from light to dark in the plugin code below, but that didn’t affect the background:

    $fburl= $url.’&layout=’.$vh[2].’_count&show_faces=false&width=71&action=like&colorscheme=light&font=arial’;
    if (!$is_IE)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Share Post] Can't activate plugin’ is closed to new replies.