Support » Plugin: AddToAny Share Buttons » [Plugin: Share Buttons by Lockerz / AddToAny] AddToAny Sharing Plugin Widget won't load: Twenty

  • Resolved Wicketty Wabbit


    I’ve tried dragging the widget to a functioning widget area and hard coding it in style.css. Neither seems to work.

    My website and blog are here:

    Hard coding displays a little square black dot beside the “search” widget I have in my footer. But aside from that, no evidence that AddToAny exists on my site.

    I tried removing all my plug-ins except Akismet and replacing only AddToAny. No go.

    I moved my “search” widget to the places I want to put AddToAny, and it works wherever I put it. But AddToAny doesn’t work no matter where I drag it.

    I tried hard coding it into style.css by adding the code suggested on the AddToAny FAQ:

    <?php if( function_exists('ADDTOANY_SHARE_SAVE_BUTTON') ) { ADDTOANY_SHARE_SAVE_BUTTON(); } ?>.

    I put it just before the content in style.css and at the top of the footer. No go.

    I’m new to html, and perhaps my attempt to add comments around the code has invalidated it? I put notes in starting with /* and ending with */ so I could see later what I had done to alter my child theme’s style.css file. I hope that isn’t causing the problem.

    Any suggestions where I might look?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve also tried changing themes temporarily. The AddToAny Share button wouldn’t work in my Twenty Ten child theme, but it also wouldn’t work in Twenty Ten or Twenty Eleven.


    Plugin Author micropat


    Can you try reenabling the plugin so we can take a look here?

    You should undo your customizations. PHP code (<?php if( function_exists('ADDTOANY_SHARE_SAVE_BUTTON') ) { ADDTOANY_SHARE_SAVE_BUTTON(); } ?>) should definitely not go in a CSS file.

    Go to Settings > AddToAny > then Reset your settings.

    Also, try temporarily disabling other plugins, especially any kind of “caching” plugin that you have enabled.

    Thanks for your reply.

    I have removed all the customized code from all main Theme files, and have removed the custom code for AddToAny Share from my child theme files.

    All the plugins are deactivated except the AddToAny Share, and its settings are set and saved so that it should show up in the second footer widget area.

    The only other widgets activated are “Search”, “Archive” and “Recent posts”.

    AddToAny doesn’t show up.

    Plugin Author micropat


    The plugin doesn’t seem to be enabled at all. Do you positively have it enabled, and have you cleared any sort of caching mechanism that you may have in place? In the source, we should at least be able to find AddToAny-related strings such as “a2a”.

    The plugin reads “activated” on the dashboard. I deactivated it, dragged it into place again, and re-set everything, and it shows as activated.

    I’ve cleared my browser’s cache, and AFAIK there’s no other caching device in operation.

    Very strange. The odd thing is that I’ve tried other “share” widgets and none of them work, either. But I haven’t tried installing the other shares and testing them with the theme set temporarily as Twenty Eleven.

    This is quite frustrating. The last step in getting my site working properly, and it’s taken me several DAYS of checking files, trying various workarounds, etc. The WordPress Sharing widget worked fine over on But self hosting has raised some baffling issues.

    This morning I deactivated and removed the AddToAny share widget.

    Next, I temporarily changed to the Twenty Eleven theme, downloaded a different plug in sharing widget (social sharing toolkit), activated and configured it. It doesn’t show up in Twenty Eleven, either.

    Plugin Author micropat


    FYI this plugin is designed to automatically place a sharing button below your posts and pages upon activation. Since the issue isn’t related to this plugin, you should mark this as resolved and possibly start a new topic on the greater issue.

    Before you start a new topic, you might try checking with your host or troubleshooting your plugins directory if everything else on your site is working as expected.

    I hope you’re right, and it seems it’s not just the plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Share Buttons by Lockerz / AddToAny] AddToAny Sharing Plugin Widget won't load: Twenty’ is closed to new replies.