Support » Plugin: Share and Follow » [Plugin: Share and Follow] Icons do not display after fresh install

  • Resolved SecGen

    (@secgen)


    Hi,

    I’m currently using AddtoAny, but some of the features of Share and Follow are appealing and I am considering a switch.

    Unfortunately after I install Share and Follow, the share icons do not show up, and the tab on the right side of the screen does not look properly formatted.

    You can mouse over where the icons are meant to be, and see the hyperlinks – but no icons themselves.

    Any ideas?

    http://wordpress.org/extend/plugins/share-and-follow/

Viewing 15 replies - 1 through 15 (of 43 total)
  • I’ve recently installed this plugin, and I’ve had the same problem as you have. I’ve discovered why.

    This plugin is user tracking. I checked stylesheet.css in /wp-content/plugins/share-and-follow/ and found that the icons are being pulled from a third party website:

    .size16 .twitter{background: transparent url(http://www.city-zen-clothing.com/wp-content/plugins/share-and-follow/default/16/twitter.png) no-repeat}

    Changing the URL from the stylesheet to relative paths fixes the issue.

    Hi solidpark,

    Thanks for the info. Indeed hotlinking isn’t good practice, and I hope this can be taken out of the plugin. That said, it doesn’t appear to be the hotlinking that’s causing the problem on my end. When I check the source, all of the Share and Follow icons are set to blank.png

    http://www.domain.com/wp-content/plugins/share-and-follow/images/blank.png

    So naturally nothing is displayed. But why would it be doing this?

    I was missing the icons, too.

    WordPress 3.0.1
    Sahre and Follow Version 1.21.6
    Theme: The PaperCore by Pexeto

    I had installed the plugin using the Add Plugins auto installation and then had upgraded from WP 3.0 to 3.0.1 some time after that.

    I deleted the Plugin from within WordPress. Then instead of using the auto-install, I downloaded Share and Follow, unzipped it, and uploaded the share-and-follow folder to wp-content/plugins using an FTP program. The icons appeared after that. And all of my Share and Follow settings were intact, too.

    Wat was truly odd before I tried the fix described above was that when I copied the URL to any of the icons and pasted that into a browser I got a File Not Found error even though my FTP program and server Control Panel’s File Manager indicated that the icon files were indeed there.

    Anyway, given my configuration as listed above, deleting the plugin from within WordPress and then uploading it via FTP solved the missing icons problem.

    Hi artsmo,

    Thanks for the tip, unfortunately this didn’t fix it for me.

    Any comment from the dev?

    I haven’t received or seen any news on this. But it is still working for me. I wonder if there are permissions issues. . .? Most of my stuff in that plugin directory is set to 755 or 754.

    Plugin Author andykillen

    (@andykillen)

    Hey All

    Please check the latest version of the plugin and see if that fixes it for you, I have removed substantial amounts of CSS and also changed the way the icons are generated. Hopefully that should fix any compaibility issues that you are facing.

    version 1.50 should be the one for you.

    Please let me know if you still have issues
    All the best
    Andy

    Hi andy,

    Thanks for the update! Making progress… the icons are now appearing! Only one small thing is still missing, the Follow tab on the right side doesn’t display correctly. The text is horizontal, whereas it should be vertical (although the icon is appearing now).

    Any ideas?

    Plugin Author andykillen

    (@andykillen)

    Hey SecGen,

    What I think will be the quickest solution for you is to. . . .

    1. Open your website with an FTP client (example written using Filezilla)
    2. change to the /wp-content/plugins/share-and-follow/css/ directory
    3. highlight stylesheet.css and the right click and select File Permissions
    4. Change the file permissions for that file to 644

    do the same for print.css

    if that does not resolve it, try 777 (total hammer to crack a nut approach)

    all the best
    Andy

    Hi Andy,

    Thanks for the tip. 644 didn’t work, but 777 did! So much for the nut.

    I have a few questions about Share and Follow:

    1) Is it possible to set the order in which the share links (icons) are displayed?
    2) Is it possible to have an ‘other’ link/icon that shows all of the other share options whose icons are not shown on the page itself?
    3) is there a way to prevent the share links from appearing on any given page/post? Add2Any allows you to put an html comment like <!–nosharesave–> to stop the links from being displayed.

    Thanks again, I look forward to trying out the plugin. I’ve been considering replacing Add2Any, but want to make sure I have all the features I need.

    Hi Andy,

    A bit off-topic for this thread, but clicking on the Bookmark icon to save a page/post as a bookmark currently tries to bookmark as follows in Firefox:

    javascript:window.bookMark(‘http://blog.com/post’, ‘Post+Name’,%20BrowserDetect.browser);

    ie. The bookmark contains the full javascript, which means that clicking on that bookmark doesn’t work.

    Just updated to the latest version and had to 777 those two css files again. Is there a reason I’m having to do this, and can it be fixed on the plugin side?

    I’m assuming some other users are also having this issue.

    Plugin Author andykillen

    (@andykillen)

    Hey SecGen

    I can’t say why some servers do not allow or setup automatically this file. It should install perfectly with the default settings of 644 and be working. I can only guess there is a different config on your server

    and for the bookmark stuff, I’ll take another look at that one. thanks for the pointer

    regards
    Andy

    Plugin Author andykillen

    (@andykillen)

    Hey SecGen again….

    I’ve looked into the coding of the stuff and it’s correct, I think it’s something to do with the release of firefox last week. I think that update screwed things up. I’m gonna contact Mozilla to have a chat and work it out with them

    regards
    Andy

    Thanks for the bookmark fix… bookmarking works now, only one small thing remains and that is that the post name in the bookmark has + instead of spaces.

    eg. My+post+name

    Any thoughts on my queries below?

    1) Is it possible to set the order in which the share links (icons) are displayed?
    2) Is it possible to have an ‘other’ link/icon that shows all of the other share options whose icons are not shown on the page itself?
    3) is there a way to prevent the share links from appearing on any given page/post? Add2Any allows you to put an html comment like <!–nosharesave–> to stop the links from being displayed.

    Thanks again.

    My issue is that the widget sidebar no longer displays the follow RSS feed icon and text, even though that is checked in the widget sidebar options setting. it worked fine before the last couple of revs.

    ?

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘[Plugin: Share and Follow] Icons do not display after fresh install’ is closed to new replies.