WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03

[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03

  • I’m actually on WordPress 2.9.2

    I upgraded this morning to the latest version of the plugin. Since then Shadowbox JS does not work at all.

    So far I’ve tried:

    • Deactivating and reactivating
    • Uninstall/reinstall
    • Tried each different JS library – none have any effect
    • Deleted all cached pages and the browser cache – no change
    • Enabled/disabled smart loading, neither makes a difference.

    What should I do? Go back to the previous version?
    Previous version worked perfectly, I should’ve stuck with it..
    ——–
    Also, I have disabled the img title push plugin as it prevents the img displaying if there is a title already there which is different to the title in the anchor. I don’t really need this functionality anyway, I’m just letting you know that there’s some kind of conflict there.
    ——–
    url: http://tgcgs.com

    http://wordpress.org/extend/plugins/shadowbox-js/

Viewing 15 replies - 31 through 45 (of 65 total)
  • daganloy@gmail.com:

    As I keep telling everyone, I cannot troubleshoot a problem when there is no problem. If a problem presents itself after making a change, then you need to leave that change and thus leave the plugin broken. If you revert the settings and I cannot see the problem then I cannot troubleshoot said problem.

    Sivel: Sorry about that i was just playing with it and I forgot to leave it broken for you to see. I have changed it to jQuery and Modal to true. My theme uses jQuery so I assume that would work fine. The older version of Shadowbox I had it on jQuery as well and it worked fine.

    daganloy@gmail.com:

    Ok, the problem seems to be with how this plugin stores it’s cached copy of shadowbox.js.

    In your case the cached file has been stored at:

    http://www.trumoments.ca/wp-content/uploads/shadowbox-js/aef9fa4ac9bd82bcd0d46928b145c6b0.js

    However it appears as though this file can not be read properly by the web server, and is returning a 404. Please check to make sure this file exists and that the file system permissions permit it to be read by everyone.

    That file would exist in wp-content/uploads/shadowbox-js/aef9fa4ac9bd82bcd0d46928b145c6b0.js of your WordPress install.

    Alternatively you could also just try deleting that file if you are unable to get it to stop returning a 404 file not found, this plugin would then fall back to building shadowbox.js on the fly and delivering it through admin-ajax.php

    Hi Sivel,

    Thanks a lot for you time. But it seems that I don’t have that file? I have a bunch of files in there, but not that one. I went and checked all the permissions and it’s set for anyone. I went ahead and deleted all the files in that upload/shadowbox-js/ folder.. then i disabled the plugin, then enabled it again to see if i could make it fresh.. The problem still exists.

    I am going to try a completely fresh install to see how it goes.

    *UPDATE:
    Okay after all that deleting and fresh installing, the plugin seems to not even work at all, even when i reset it to default from the shadowbox settings menu.. What could possibly be the problem?

    Configure the plugin the way that you want it, then delete the directory wp-content/uploads/shadowbox-js and test again, after deleting the directory to not make any modifications to the configuration.

    On another note, I checked your site and it is working now.

    The problem seems to be that the file is getting created but not with the correct file permissions causing the check for file_exists to pass but not actually work as expected.

    The current file that is created is: http://www.trumoments.ca/wp-content/uploads/shadowbox-js/38d81d42ef30ac1f746f9b2e7a646b40.js

    If you want to try something else edit wp-content/plugins/shadowbox-js/inc/frontend.php and change the only reference to file_exists to is_readable. Making that change would likely solve this problem all together, and is going to likely been in the next release of the plugin.

    It seems to be working for you? Can you confirm this again? Because I just tried ALL of your steps and its still not working. It just jumps to the movie file.. i clear my cache and refresh the page everytime I check and still nothing.

    Sivel, perhaps if you have skype or msn, I could provide you server access so you can get a better controlled look?

    Hi Sivel. I have tried everything to get Shadow box working, reset, turned other plugins off but still have the same problem. When I tried to delete for a clean install I get the following message.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 514

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 514

    Warning: Invalid argument supplied for foreach() in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 520

    Warning: Cannot modify header information – headers already sent by (output started at /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php:514) in /home/davrodi/public_html/wp-includes/pluggable.php on line 868

    Thanks David

    I’m about to literally pull my own hair out over here. I tried out the plugin on a wordpress-installation (along with many others), finally deciding this was the one to use. Adn it worked perfectly, no problems at all.

    So I head on over to my other wordpress installation, which more or less had the same plugins and they were both running WordPress 2.8.7. I install the plugin on this other wordpress installation, and, of course, it doesn’t work. The links just open the videofile as a new page instead of using the Shadowbox. I think to myself, well maybe I have to update my wordpress, and get the latest, 2.9.2. Still the same problem. I deactivate every other plugin. Still same problem. I switch theme to the default. Still the same problem. I try earlier versions of the plugin, still the same problem. I just don’t know what I’m missing here, so a little help would be much appreciated.

    You can check a temp-page with example of links, not working, on this link: http://bdforum.se/vc/temp

    It’s password-proteced since it has nothing to do with the rest of the site, Password: shadowbox

    Hope someone can lend a helping hand, because the plugin was perfect when I had it working on the other installation.

    davro10: That means that you have unchecked every one of the players listed at Settings->Shadowbox JS. Doing so will not let shadowbox work at all.

    @svenzn:

    I have taken a look at your site and firebug is returning an error:

    invalid object initializer
    http://bdforum.se/vc/temp
    Line 241

    That line number refers to:
    <a href="http://www.youtube.com/v/uz1hUj7buYc" rel="shadowbox[post-2175];player=swf;width=650;height=385;">Youtube</a>

    I tested this exact line on my install and it works without any problem which leads me to believe it may be a theme/plugin conflict. Disable all plugins and test again, if it works then one of your plugins is conflicting. If this doesn’t solve it, switch to the default theme and test it, if it works then your theme is causing the conflict.

    I just tried disabling all the plugins, but that didn’t help, so I tried using the default theme while all the plugins were disabled as well, but that didn’t work either. Gonna try and disable the adds on the site, see if that helps because I really can’t see what’s causing the problem, since it works fine on a separate wordpress-installation on the same server…

    Edit 1: Scratch that last part about adds, because I just realized there aren’t any on te test-page πŸ˜›

    Edit 2: Okey, so I just ruled out the theme as the perpetrator because I installed the theme on the other wordpress-site and it works just as well as before on that one. *sigh*

    Sivel: Posted this message on your site, but after careful reading I saw that I have to post my problems here…. my apologies.

    Great plug-in… but the newest version 3.0.3.2 will not work (with images) on my site. I have to use an older version like 3.0.0.3. (I use the Mimbo theme). When an image is clicked, the image is shown on a new page in the same window…. so no shadowbox.

    http://www.niekfotografie.nl/2010/01/basilica-di-san-marco/

    I’m getting this error:

    Error: Shadowbox is not defined
    Source File: http://www.niekfotografie.nl/2010/01/basilica-di-san-marco/
    Line: 295

    Update: it seems to be working now after changing file permissions in wp-content/uploads/shadowbox-js

    Hi Sivel I have checked all the boxes and tried every option after reading this thread. I have even deactivated other plug-ins which I think is what you meant but still the same problem. It seems flv files download and mov files open full screen. I’ve tried both flv and mov incase that was the problem.

    I have installed this before without a hitch and it work brilliantly until the update.

    Thanks david

    Got it working now after uninstalling the plugin from the other wordpress-site and the current, as well as disabling all plugins and reverting to Default theme and then installing the plugin so that it was the only plugin installed, followed by activating the other things one by one. And no, can’t say I see the logic in why it works now and not before, but it does, so I’m happy, I guess. πŸ˜› Thanks for a great plugin!

    Update: it seems to be working now after changing file permissions in wp-content/uploads/shadowbox-js

    But when new files are created under the wp-content/uploads/shadowbox-js dir, then those new files do not have the right permissions. I have to manually change the permissions (with for example Filezilla). New files are created with permission 660.

    Any idea?

    PS. Not all files are cached under wp-content/uploads/shadowbox-js? I can only see a couple, not for all of my images. I made the change you suggested earlier:

    If you want to try something else edit wp-content/plugins/shadowbox-js/inc/frontend.php and change the only reference to file_exists to is_readable.

    This does not solve my problem.

Viewing 15 replies - 31 through 45 (of 65 total)
  • The topic ‘[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03’ is closed to new replies.