Support » Plugins and Hacks » [Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03

[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03

  • I’m actually on WordPress 2.9.2

    I upgraded this morning to the latest version of the plugin. Since then Shadowbox JS does not work at all.

    So far I’ve tried:

    • Deactivating and reactivating
    • Uninstall/reinstall
    • Tried each different JS library – none have any effect
    • Deleted all cached pages and the browser cache – no change
    • Enabled/disabled smart loading, neither makes a difference.

    What should I do? Go back to the previous version?
    Previous version worked perfectly, I should’ve stuck with it..
    Also, I have disabled the img title push plugin as it prevents the img displaying if there is a title already there which is different to the title in the anchor. I don’t really need this functionality anyway, I’m just letting you know that there’s some kind of conflict there.
    url: http://tgcgs.com


Viewing 15 replies - 16 through 30 (of 65 total)
  • Hello.
    Here is not working at all since updated to 3.03 version.
    Example: http://www.experienciadigital.es/2010/03/kaspersky-pure-el-nuevo-antivirus-para-usuarios-dometicos-mas-completo-de-kaspersky/

    I have done all have been said in this thread.
    I have a premium theme.

    In my web lines are these too:

    flashParams: <p>{bgcolor:"#000000", allowFullScreen:true}</p>
    		flashVars: <p>{}</p>

    Any help?

    Thanks a lot!

    I am not entirely sure what is happening here, and I have not been able to duplicate it, however I just released an update to the plugin that may help, after the update shows up please install and give it a shot. Let me know if it helps.

    Hi sivel,

    great, now it works again correct.

    But – i still get no close-button 🙁

    Can you tell me whats wrong here?

    Thx, Frank

    Thanks a lot!
    For me, now it’s working ok.

    Thanks a lot!

    For anyone that cares, I was using wp_htmledit_pre to filter those 2 lines, and apparently there are some themes and such which hook into that filter which caused <p> tags to be added and then escaped.

    @fk59: from looking at the behavior on your site I am inclined to believe it is a conflict with another plugin.

    Brilliant Sivel!
    With your update it works perfectly also in WP 2.9.1. Great!
    Resetting to defaults didn’t work with v 3.0.3. For some reason, instead of the default settings in the “Flash Params” and “Flash Vars” fields (under Advanced configuration), some <p> tags where added – just as you said half an hour ago. In other words, it was possible to see it quite easily – if one only knew what to look for:
    Flash params:
    <p>{bgcolor:"#000000", allowFullScreen:true}</p>
    instead of
    {bgcolor:"#000000", allowFullScreen:true}
    (should be the default setting) – and
    Flash Vars:
    instead of just
    And deleting the <p> tags didn’t help – they just showed up again. (They still do, but they don’t cause any problems.)
    Just to let you know how it looked here.
    A big thanks again,
    PS Using the Atahualpa theme and WP 2.9.1
    PPS No plugin conflicts neither, though I need about 40. Complex site…
    PPS Just discovered that you have to remove the <p> tags and Save to make it work. Even though they reappear after saving, removing them first makes a big difference. At least here.

    Hi Sivel, I have been having a lot of problems Since this upgrade, kind of sucks, but I can’t seem to figure out what’s wrong. I even upgraded it to the recent one you have. this is my link:

    <div class="button_for_films"><a rel="shadowbox;width=800;height=340;title=;" href="/films_files/2009/1_2009_Wedding_Demo_Reel.mov">Play Demo Reel</a></div>

    and it was working absolutely fine, so I’m sure nothings wrong with that code..

    Another concern for me is the “Modal” option.. I’d like to have it to true, since some of my users accidentally click the background lots.. and it was set to true, until after the upgrade, and when I set it to true it didn’t work either..

    any information will help a lot, thanks!

    Hi Sivel,

    Okay I did a little self-troubleshooting. Now I reset all the functions to default using the reseter on the settings page. It started working again, GREAT. BUT, what I would still like is for the Modal to be turned on so that if the visitor clicks overlay, it doesn’t go anything. But the problem is, when I turn Model to “true” it’s like it disables Shadowbox completely! Then when I try and change it back to false, it brought me back into the same problem before, where no matter what settings I choose it will just not work at all. If i reset it to default, its working again. Modal somehow screws it up, and also I seem to be having this problem when I set the javascript library from “None” to “jQuery”.

    Oh and here is the link to the page I am using it on. It’s obviously the Play button.


    After another bit of troubleshooting, I tried tweaking the admin.php file to set the default values to what I want, then I “reset” to these settings to that to see if I can get that to work temporarily. After I change the Modal to true, and reset it to this “Default” it still does not work. Then I reverted the admin.php default settings back, reset it to that and it works again, but still the problem where Modal or Javascript libraries won’t work if settings are changed…

    Hope that helps!


    I’m having a lot of problems since updating to When you click on the play button the videos just start to download or open full screen.

    I’m using WP 2.9 .2

    I have check all the settings and read through this thread but no go so far.

    Thanks for any help

    daganloy@gmail.com: I just tested the modal settings as of a few minutes ago. When set to ‘false’ in the admin, clicking outside of the overlay will close it, when set to ‘true’ clicking outside does not cause it to close. So it appears to work as documented. Currently on your site I see that it is set to ‘false’. To modify this setting in the admin go to Settings->Shadowbox JS, click the “Show Advanced Configuration” button, scroll down to Modal and set it to ‘true’ and then click ‘Save Changes’.

    If that fails to work for you then it is a conflict with either your theme or another plugin.


    I cannot see that the plugin is even activated. I don’t see the url to shadowbox.css in the head, I don’t see any of the configuration in the footer, and I don’t even see the word “shadowbox” in the source of the page at all.

    Thanks for the reply Sivel. Both Shadowbox JS and Shadowbox JS Use Title from Image are activated, the problems are the same as the comments above. If the code is missing could it be the theme and what would need to be added if it is..?

    This page the video opens full screen, other start to download the videos

    Thanks again

    Hi Sivel,

    Yes I know where to change the Modal settings, otherwise I wouldn’t know what Modal does. I don’t see how Modal can be in conflict with other plugins or themes? As Shadowbox older version didn’t have any of these conflicts with my theme, and I haven’t touched anything else since the upgrade. I have now turned it on to True, and now it doesn’t even work. I will try disabling other plugins though.


    Hi Sivel,

    I tried deactivating all the plugins and still no luck. It doesn’t make sense the Modal would affect the entire plugin to stop working? What I don’t get is why there would be a conflict now with the theme, when there was no conflict before the upgrade. I had set Modal to true on the older version and it worked perfectly fine.

    Thanks again!

    UPDATE: it seems as though if there are ANY settings changed, the Shadowbox plugin won’t work.. THe only way I can get it to work right now is by resetting it to default. Any changes to the javascript settings(visual settings such as overlay color work fine) will cause the entire script to not work..

Viewing 15 replies - 16 through 30 (of 65 total)
  • The topic ‘[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03’ is closed to new replies.