WordPress.org

Forums

Shadowbox JS
Shadowbox-js stopped working -- what else can I try? (12 posts)

  1. Rosie-L
    Member
    Posted 2 years ago #

    I have had Shadowbox-JS running for some time, when it suddenly stopped working recently, such that now when images are clicked on they just show up on a blank browser page, instead of in the Shadowbox like they used to.

    I have tried deactivating and deleting Shadowbox-JS, then reinstalling from a fresh download of the plug-in (shadowbox-js.3.0.3.10.2.zip) but nothing changes.

    I note in your FAQ the following statement:
    "Neither Shadowbox nor the JW FLV Player are actually included in this plugin. The plugin will ask you to download these files after installation and activation."

    However the reinstallation does not ask me to download any further files. Assuming that I have to do it myself, I downloaded shadowbox-3.0.3.zip, but what do I do with it?

    The Next I tried changing "Delete Options for a Clean Uninstall" to true, but on saving changes, I get:

    Warning: file_get_contents(/home/asob63/public_html/blog/wp-content/uploads/shadowbox-js/src/players/.js) [function.file-get-contents]: failed to open stream: No such file or directory in /home/asob63/public_html/blog/wp-content/plugins/shadowbox-js/inc/admin.php on line 654

    Warning: Cannot modify header information - headers already sent by (output started at /home/asob63/public_html/blog/wp-content/plugins/shadowbox-js/inc/admin.php:654) in /home/asob63/public_html/blog/wp-includes/pluggable.php on line 881

    I have also tried:

    - Changing the Javascript Library to jQuery and Prototype.
    - Toggling Enable Smart Loading between true and false.
    - Toggling cached shadowbox.js between true and false.

    Can you help please?

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. Rosie-L
    Member
    Posted 2 years ago #

    UPDATE...

    I uninstalled the plug-in again, then used my FTP program to delete any Shadowbox-related files in: /public_html/blog/wp-content/uploads/shadowbox-js.

    This time when I reinstalled I did get the message about missing source files and clicked the button to install them.

    Installation proceeded without errors, and now the /wp-content/uploads/ folder contains the subfolder shadowbox-js.

    My images have the word shadowbox in the Link Rel field under Advanced Link Settings.

    Unfortunately still no Shadowbox happening -- clicking an image just opens it on its own browser page.

    This is really annoying because it used to work just fine!

  3. Rosie-L
    Member
    Posted 2 years ago #

    MORE INFORMATION:

    Hmmm, I wonder if this is a path problem, as in the Shadowbox files can't be found under certain circumstances. Here is what led me to that possibility...

    On the WordPress homepage, where the latest and other recent posts appear, a Shadowboxed image pops up in the Shadowbox as expected when clicked.

    However, if you go to the full article by clicking on the post's title, clicking on the same image as before displays the bare image on another browser tab, NOT in the Shadowbox.

    Of course, whether on the homepage or the full-Post page, the code for the image is EXACTLY the same. E.g.

    <div id="attachment_1633" class="wp-caption aligncenter" style="width: 300px">
    
    <a href="http://domainname.com/blog/wp-content/uploads/2012/03/1.png" rel="shadowbox" title="This is the title"><img class="size-medium wp-image-1633   " title="This is the title" src="http://domainname.com/blog/wp-content/uploads/2012/03/1-300x225.png" alt="Some alt text here" width="300" height="225" /></a>
    
    <p class="wp-caption-text">This is the caption below the image.</p>
    
    </div>

    The WordPress homepage is the ONLY place where a clicked image opens in the Shadowbox. Anywhere else, e.g. on pages, the bare image opens in a new browser tab without the Shadowbox.

    Any ideas?

  4. stueynet
    Member
    Posted 2 years ago #

    I am finding that the shadowbox css and js files are not loading on all pages. Some pages it loads and some it doesn't. This is what is causing it not to work despite having the rel=[shadowbox] added to the image links. The plugin is not loading the required scripts.

  5. Rosie-L
    Member
    Posted 2 years ago #

    Hi stueynet.

    That's what I guessed, but what to do about it?

    I wish Mr Shadowbox would give us some direction on this, because it's really broken the appeal of my site.

    Actually, it's not even my site, but one I'm managing for someone else, and understandably they are not very happy about it not getting fixed.

    Maybe there is a more reliable Shadowbox plug-in available? any suggestions, anyone?

    - Rosie

  6. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    If the scripts and css are not loading on every page for you, try Setting "Enable Smart Loading" to "false" in the Shadowbox JS plugin settings page.

  7. Rosie-L
    Member
    Posted 2 years ago #

    Matt, my "Enable Smart Loading" has been set at "false" all along!

    As far as I can see, Shadowbox is only loading on one page -- the homepage.

    How can I completely zap all traces of Shadowbox, including any entries in the MySQL database, so that I can try a completely fresh install without risk of picking up anything left over from the current installation?

  8. BillHely
    Member
    Posted 2 years ago #

    No offence intended Matt, but you seem to be troubleshooting by shotgun rather than sniper rifle. Random suggestions to enable this/disable that may or may not hit the target. OK, admittedly the people asking for assistance with this problem aren't giving you the information you need, so I'll attempt to do that.

    I have a site with exactly the same problem: Shadowbox loads on some pages (well, only one actually) but not others, where it previously ran on all pages just fine. The problem started after a WordPress upgrade.

    The logical approach is to compare a working page with one that no longer works, so here's the result of doing just that...

    *** WORKING PAGE ***

    Apart from the rel="Shadowbox" tag in each image reference, the working page contains the following references to the term "shadowbox"

    <head>
    <link rel='stylesheet' id='shadowbox-css-css'  href='http://domainname.com/blog/wp-content/uploads/shadowbox-js/src/shadowbox.css?ver=3.0.3' type='text/css' media='screen' />
    <link rel='stylesheet' id='shadowbox-extras-css'  href='http://domainname.com/blog/wp-content/plugins/shadowbox-js/css/extras.css?ver=3.0.3.10' type='text/css' media='screen' />
    </head>
    
    <body>
    <!-- The following appears towards, but not at, the bottom of the body section -->
    <script type='text/javascript' src='http://domainname.com /blog/wp-admin/admin-ajax.php?action=shadowboxjs&cache=487b3d6f31bf87438edf438705c40481&ver=3.0.3'></script>
    
    <!-- Begin Shadowbox JS v3.0.3.10 -->
    <!-- Selected Players: html, iframe, img, qt, swf, wmp -->
    <script type="text/javascript">
    /* <![CDATA[ */
    	var shadowbox_conf = {
    		animate: true,
    		animateFade: true,
    		animSequence: "sync",
    		modal: false,
    		showOverlay: true,
    		overlayColor: "#000",
    		overlayOpacity: "0.8",
    		flashBgColor: "#000000",
    		autoplayMovies: true,
    		showMovieControls: true,
    		slideshowDelay: 0,
    		resizeDuration: "0.35",
    		fadeDuration: "0.35",
    		displayNav: true,
    		continuous: false,
    		displayCounter: true,
    		counterType: "default",
    		counterLimit: "10",
    		viewportPadding: "20",
    		handleOversize: "resize",
    		handleUnsupported: "link",
    		autoDimensions: false,
    		initialHeight: "160",
    		initialWidth: "320",
    		enableKeys: true,
    		skipSetup: false,
    		useSizzle: false,
    		flashParams: {bgcolor:"#000000", allowFullScreen:true},
    		flashVars: {},
    		flashVersion: "9.0.0"
    	};
    	Shadowbox.init(shadowbox_conf);
    /* ]]> */
    </script>
    <!-- End Shadowbox JS -->
    
    </body>

    And Shadowbox on that page works fine, but now let's look at a...

    *** NONWORKING PAGE ***

    <link rel='stylesheet' id='shadowbox-css-css'  href='http://domainname.com/blog/wp-content/uploads/shadowbox-js/src/shadowbox.css?ver=3.0.3' type='text/css' media='screen' />
    <link rel='stylesheet' id='shadowbox-extras-css'  href='http://domainname.com/blog/wp-content/plugins/shadowbox-js/css/extras.css?ver=3.0.3.10' type='text/css' media='screen' />

    That's It! Seems like there's a whole block of JavaScript missing.

    So if that is indeed the problem, the question becomes "What to do about it?"

    Since each WordPress page (as displayed in a browser) is assembled on demand from various components such as database objects, config files, and so on, no completed page resides on the server. So it's not a matter of just going to each nonworking page and inserting the missing code block towards the end of the body section.

    But unfortunately that's the limit of my knowledge as to how WordPress works. I have no idea how to get the missing code into the final output of the appropriate pages. I would have thought that a reinstallation of Shadowbox would do the trick, but it didn't. Perhaps Rosie's question about a way to totally eliminate all traces of Shadowbox before trying a reinstallation might be pertinent.

    So there's the problem Matt. How do we fix it? Over to you.

  9. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    First things first, I need a URL to where I can see shadowbox working and a URL where I can see it not working. I cannot troubleshoot from random copy pastes without having any context.

    In addition, disabling Smart loading is not a shotgun blast, in fact that is the easiest way to ensure that shadowbox loads on all pages without requiring too much troubleshooting effort from either side.

    I'd also like to state, that as of July 6 I will no longer be supporting any of my plugins on a regular or consistent basis.

  10. stueynet
    Member
    Posted 2 years ago #

    I had this problem. Just reset your settings in the plugin. There are checkboxes at the bottom of the settings page.

  11. Florence
    Member
    Posted 2 years ago #

    I'm having the same issue. Have you guys found a way? Or another plugin?

  12. tonysmithdesign
    Member
    Posted 2 years ago #

    I'm not sure if this will help but I spent 2 days working on my issue.

    I manage multiple sites and have been using Shadowbox JS on several of them. I installed the plugin on all of them using the WordPress Admin > Plugin panel. Until recently this was fine but the plugin failed to work on the latest site I'm in the process of building. To be more specific, the plugin partially worked but failed to open images in a light box. The plugin did generate the required (rel="shadowbox...") attribute for all links with images but for some reason images would only open in a page and not in a light box.

    My solution was to go to the author site (http://www.shadowbox-js.com/download.html) and download the source files manually. I selected all the player options, downloaded the source files, then uploaded only the shadowbox.js file to my server. I chose the location wp-content/plugins/shadowbox-js/js/shadowbox.js for my purposes but this shouldn't matter. Keep in mind, this is in addition to retaining the active version of the plugin already installed in the Admin panel.

    I then updated my header.php file to include a static reference to the shadowbox.js file AND included the Shadowbox.init(); call like below. I tried commenting them out individually and it turned out that both needed to be included for it to work. In addition, this update had to be included below the default <link> and <script> tags that the plugin generates.

    <link rel="stylesheet" type="text/css" href="http://oxygenfactor.com/site/wp-content/uploads/shadowbox-js/src/shadowbox.css">
    <script type="text/javascript" src="http://yoursite.com/wp-content/plugins/shadowbox-js/js/shadowbox.js"></script>
    <script type="text/javascript">
    Shadowbox.init();
    </script>

    So to summarize...

    1. Have Shadowbox JS plugin already installed.
    2. Go to http://www.shadowbox-js.com/download.html to download source files
    3. Upload only the shadowbox.js file to your server
    4. Place the included code below the default <link> and <script> tags that the plugin generates.

    Not sure if this helps everyone but it worked for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Shadowbox JS
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic