WordPress.org

Forums

Shareaholic | share buttons, related posts, social analytics & more
[Plugin: SexyBookmarks | email, bookmark, and share buttons] Stop updating so much (12 posts)

  1. archonic
    Member
    Posted 4 years ago #

    I know every time this is updated, people get rid of the annoying "Hey this plugin was updated! Better go to the settings page and just hit save!" message, and a few people will click the donate button. I know you want to get paid for your efforts and you should but updating so often and putting that annoying message in is a scam way to get income. So please stop.

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Shareaholic
    Member
    Plugin Author

    Posted 4 years ago #

    Hi archonic!

    To clarify, we do not ask for donations (there isn't even a way to give us a donation :), and the basic version of SexyBookmarks is completely free.

    We like to continually improve SexyBookmarks to make it perfect vs. sit on updates/bug fixes/compatibility upgrades... better than no updates/buggy plugin, right?

    http://wordpress.org/extend/plugins/sexybookmarks/changelog/

  3. Shareaholic
    Member
    Plugin Author

    Posted 4 years ago #

    Btw, it is important to understand why we ask users to re-save settings:

    When you save your settings, the plugin grabs a custom sprite png file (based on which services you pick) from our servers and saves them on your server (/spritegen directory). The master sprite image that ships with SB contains over 60+ buttons and is over 200kb big. Since most publishers choose to display <10 buttons on their webpages why load 60 buttons when 10 buttons are enough. Using custom sprites makes everything a lot faster for your readers.

    When you update SexyBookmarks, the custom sprite unfortunately gets deleted by WordPress. This is why we ask you to re-save your SB settings on update. Note: starting with v3.3.12 - if you choose not to re-save your settings, SB will still work. It now defaults to the master sprite file automatically.

    We'll look into whether can just automatically do the custom sprite step on upgrade behind the scenes.

  4. JonathanMurray
    Member
    Posted 4 years ago #

    FYI, I updated the plugin for the last time today. Then I deactivated and deleted it. Annoyance factor finally reached the breaking point.

    Find a better way to consolidate your updates so they don't come so often (unless security related, of course); include 'sprites' in the update. Do *something* to make using your plugin less annoying, and I'll happily give it another look.

  5. Bike
    Member
    Posted 4 years ago #

    I am ok to re-save settings to regenerate the sprite.

    What is much worse is that every time there is a tiny update, I also need to boot up the FTP, login to my all sites that use this and re-set the permissions to 755, as somehow the entire spritegen folder gets replaced. This takes too much time and effort.

    This is the number one reason I am now looking for a better solution.

  6. Shareaholic
    Member
    Plugin Author

    Posted 4 years ago #

    SexyBookmarks no longer needs the spritegen directory. Although it will be much faster if it did.

  7. Bike
    Member
    Posted 4 years ago #

    Well, I just updated to 4.01 and it appear that it is still as annoying:
    - On top of the settings page:

    "Help
    NOTICE: Shareaholic was just updated... Please visit the Plugin Options Page and re-save your preferences.

    Shareaholic Plugin Health Status
    Directory Permissions To Fix: Please appropriately CHMOD your /spritegen directory. "

    When saving settings, yet another CHMOD reminder + a few bonus errors:

    "

    WARNING: Your spritegen folder is not writeable by the server! Need Help?

    Warning: fopen(/home/public_html/wp-content/plugins/sexybookmarks/spritegen/jquery.shareaholic-publishers-sb.min.js) [function.fopen]: failed to open stream: Permission denied in /home/public_html/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 175

    Warning: fopen(/home/public_html/wp-content/plugins/sexybookmarks/spritegen/sprite.css) [function.fopen]: failed to open stream: Permission denied in /home/public_html/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 175

    Warning: fopen(/home/public_html/wp-content/plugins/sexybookmarks/spritegen/sprite.png) [function.fopen]: failed to open stream: Permission denied in /home/public_html/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 175
    Changes saved successfully. However, settings are not optimal until you resolve the issue listed above.

    This was when using "new" version. When switching back to "old" version, the errors disappear, but still the CHMOD warning:

    WARNING: Your spritegen folder is not writeable by the server! Need Help?

    So why would I get this warning of the directory is not needed?

  8. Shareaholic
    Member
    Plugin Author

    Posted 4 years ago #

    It is highly recommended that you do run the most optimized version of SexyBookmarks (which requires ). However, the plugin will work if you don't. In earlier releases, the plugin did not work in this case.

  9. webmasterdesigner
    Member
    Posted 3 years ago #

    Directory Permissions To Fix: Please appropriately CHMOD your /spritegen directory. " did this on 3 different servers in 30 different sites..
    I used CHMOD 777 and didnt work tried 755 didnt work! for any of them (all 30 sites on 3 different servers)...same error message. Tried FTP and Cpanel File Manager still no luck same error...stumped!

  10. HappyHimitsu
    Member
    Posted 3 years ago #

    Wow, there really are some ungrateful people on here. Not you 'webmasterdesigner' Just the fellows above bitching.

    I am having the same problem btw.

  11. Celeste - Shareaholic
    Member
    Posted 3 years ago #

    Anyone having a problem with CHMOD spritegen errors, please read the following article in our FAQ:

    http://support.shareaholic.com/customer/portal/articles/212815-frequently-asked-questions#errors

    Hope this helps! :)

  12. ponderconsulting
    Member
    Posted 3 years ago #

    I'm having the same problem and the last solution doesn't not work either. None of them work. And why did the plugin disappear from the WordPress plugin directory? What is going on?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic