[resolved] [Plugin: SexyBookmarks] Configuration panel gives a HTTP Error (6 posts)

  1. ronalds
    Posted 6 years ago #

    I can not seem to get this plugin working on my blog. I can activate the plugin just fine, but when I try go to the configuration panel I get the Sexybookmarks logo followed by this error:

    An Unexpected HTTP Error occurred during the API request.

  2. Rhand
    Posted 6 years ago #

    I would recommend you to check you Apache error log and post the errors here.

    An Unexpected HTTP Error occurred during the API request.
    is not enough to determine the problem. With the Apache errors posted here we could help you better.
    Furthermore is is unclear if all plugins are not working or it is just one (Sexy Bookmarks)? Or is this a general post installation plugin activation issue?
    NB There are more post here on the same issue on this forum. I recommend you to go through these as well.

  3. ronalds
    Posted 6 years ago #

    I have tried to do more research but have failed to find a solution so far. The Apache server log show no traces of any errors related.

    All other addons I've been running runs/installs just fine, this is a Sexybookmarks specific -issue. I have tried previous versions of the plugin ( and 2.5) and they give me the same error.

    After searching the forums I found other similar issues related to other plugins, and they recommended trying to increase the timeout value in wp-include/http.php. I changed the timeout value from 5 seconds to 15, and this solved the problem.

  4. eight7teen
    Posted 6 years ago #

    Hi ronalds,

    Sorry for the late reply, I've been away from the computer for a couple days...

    The reason you're having issues with the timeout is because SexyBookmarks uses a homegrown function to grab short URLs via the cURL command for each of your posts... It then stores each one in the database to prevent further requests if not necessary.

    Sometimes this can become an issue if the server is already heavily loaded or if the URL shortening service you chose takes a while to respond.

    I'm glad you got the issue fixed, I just thought I would let you know why you were seeing the problem.

  5. winnercat
    Posted 6 years ago #

    Hello - have used WordPress for over 3 months. Made the mistake of cancelling my hosting plan with Godaddy and they wiped out the entire blog.

    Am now putting it back on. Worked on 17.9 but got the added /wordpress on my URL. So I did as Godaddy suggested (uninstalled and then installed again. But then suddenly (with or without /wordpress) I get "An Unexpected HTTP Error occurred during the API request" if I try to change theme, upload plugin or whatever.

    How can I fix that? Changing timeout from 5 to 30 as someone suggested didn't work. Am not trying to use anything for grown-ups just things like plugin installer.

    Maybe I made a mistake when I tried to change the timeout to 30 since it was very difficult to save it, because it's in a read only document.

    Can Godaddy do something?

    Would be really grateful if anyone could help me out on this.

    All the best

  6. delectual
    Posted 6 years ago #

    Deactivating the SexyBookmarks plugin fixed the problem for me!

Topic Closed

This topic has been closed to new replies.

About this Topic