Support » Plugins and Hacks » SEO Ultimate » [Resolved] [Plugin: SEO Ultimate] Syntax error ver. 7.5.7

[Resolved] [Plugin: SEO Ultimate] Syntax error ver. 7.5.7

  • Installing version 7.5.7 produced the following error:

    Parse error: syntax error, unexpected T_IF in /home/xxx/public_html/wp-content/plugins/seo-ultimate/modules/author-links/author-links.php on line 1

    Deleting the author-links.php file worked as a temporary fix, but that’s not a very good solution. I would imagine that deleting the file will probably break something in the plugin functions.

    I also tried increasing the site memory allocation by editing wp-config.php, to no avail.

    Assistance would be appreciated!


Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Contributor John


    It sounds like there was a plugin installation failure and the author-links.php file was not downloaded correctly. Try going to Settings > SEO Ultimate > Reinstall and reinstalling the plugin.

    Nope, that wasn’t it. I downloaded the plugin zip file again, and uploaded the new author-links.php file from the fresh download. I’m getting the same error message in my admin as I posted above. So I deleted the author-links.php file again. A line-by-line comparison of the author-links.php file I just downloaded, and the one I had trouble with 2 days ago shows them to be identical.

    Then I tried deactivating the plugin, re-uploading the fresh author-links.php, and reactivating the plugin. “The plugin could not be activated because it triggered a fatal error: Parse error: syntax error, unexpected T_IF in /home/xxxxxxxx/public_html/wp-content/plugins/seo-ultimate/modules/author-links/author-links.php on line 1”

    This installation is not on wordpress.com. I have updated the WordPress core to version 3.4.1, just before I updated the SEO Ultimate plugin.

    Plugin Contributor John


    Hmm, that’s very odd, for two reasons. The first reason is that line 1 of that file is this:


    …and obviously, that’s not an “if” statement. The first line of actual code (i.e. code that’s not a comment) does include an “if” statement, but it’s this one:

    if (class_exists(‘SU_Module’)) {

    This is also odd because that same line exists at the beginning of every other module file too, so if that line was truly breaking author-links.php, then it should be breaking every other module as well. (In other words, if that line of code is the problem, then deleting author-links.php would not be effective at getting rid of the error.)

    Not to alarm you or anything, but is there perhaps a virus on your site that could be adding code to the beginning of author-links.php? If you were to re-upload the file, and if your site were to crash again, would you be able to perhaps re-download it from your site, or else use a file editor in your web host’s control panel, to view the contents of the author-links.php and see if there’s any code added to the beginning? (or perhaps even code removed from the beginning?)

    Well, I’ve solved the mystery…almost. Your response gave me the clue. For some as yet unknown reason, my FTP program is changing that file on upload so all the code is on one line. PHP on our server clearly can’t parse the file properly like that. None of the other plugin files are affected that way, nor are any of the files for the latest WordPress core update.

    I logged into the control panel file editor and copied/pasted the original code into author-links.php, and the plugin works just fine now. Now I will have fun figuring out why my FTP program messes up ONLY that file.

    Thanks, John, for your perseverance in helping me to figure out the problem.

    Hey! I get the same error. I am using Filezilla and I found what’s going wrong. Under the menu of “Transfer”, you go to “type of transfer” and change it from “Automatic” to “Binary”.
    In this way, the FTP program does not change the file when is uploaded.



    I ran into this problem today while launching a client’s web site. You all saved me a ton of work trying to figure it out. Thanks for posting!

    The solution posted by Javier fixed the issue for me too. Thanks!

    Thanks Mary & Javier for saving me hours of head-scratching.

    Thanks Mary and javierojuel for sharing the solution!

    thanks to
    Mary B.

    Ok, thanks too to Mary and Javierojuel, the solution works just fine !

    (wp 3.5.1 + seo ultimate 7.6.1 + filezilla)



    Mary and Javier,
    Thanks for solving this issue.

    Odd, I have this issue, and I installed from WP.org…

    and… delete and reinstall fixed it 🙂

    Thank you, this was a great fix to a very annoying problem! 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: SEO Ultimate] Syntax error ver. 7.5.7’ is closed to new replies.
Skip to toolbar