Support » Plugin: SEO Facebook Comment » [Plugin: SEO Facebook Comment] Uncaught CurlException: 28: connect() timed out!

  • I’m getting this error frequently today. I’ve googled it but couldn’t figure out exactly what’s the root of the problem. Could be my host? Could be Facebook?

    Fatal error: Uncaught CurlException: 28: connect() timed out! thrown in /wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 825

    The sad part is that when I get this error, my blog gets all mixed up. The headers with logo and menu disappears, so as the sidebar.

    http://wordpress.org/extend/plugins/seo-facebook-comments/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have the same problem with the following message:

    Fatal error: Uncaught CurlException: 7: couldn't connect to host thrown in /wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 825

    It’s random here. Sometimes the error is gone and the plugin works perfectly, and suddenly the error strikes again. I really don’t know what is going on.

    I disabld the plugin and enabld it again but the error is still there

    Same issue. Started today.

    Guys, what is your host provider?

    I too experiencing the same problem. I got the below error often. Please help…

    couldn’t connect to host thrown in /home/content/82/8915682/html/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 825

    Host Provider: Godaddy.com

    My host provider is Godaddy too.
    I’ve registered a ticket on their support center. They are not being very helpful. Take a look at the conversation:
    ———————-
    Guilherme Vaz
    6/22/2012
    5:00 pm

    Hello,

    I’m getting this error in my WordPress blog:

    Fatal error: Uncaught CurlException: 28: connect() timed out! thrown in /home/content/40/8883240/html/blog/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 825

    I have this SEO Faceboook Comments plugin, that uses cURL. I’ve using it for more than 4 months and this is the first time I’ve received this error. I didn’t update it.
    I think the problem might be with the server, since I’m getting a timeout error.

    I’ve tried changing this part of the code:
    public static $CURL_OPTS = array(
    CURLOPT_CONNECTTIMEOUT => 10,
    CURLOPT_RETURNTRANSFER => true,
    CURLOPT_TIMEOUT => 60,
    CURLOPT_USERAGENT => ‘facebook-php-3.1’,
    );

    Changing the CURLOPT_CONNECTTIMEOUT to 30, but still the error persists.

    ————————

    Go Daddy Support
    6/23/2012
    2:56 am
    Dear Guilherme,

    Thank you for contacting Online Support. I understand you need assistance with your site azulestrelado.com.br.. I have tested your site and was unable to duplicate any issues at this time.

    We understand this does not signify that no issues exist but without being able to duplicate what you are describing it is extremely difficult to verify the root cause of the issue. If you are seeing this occur intermittently and believe this is related to a server-specific issue we recommend that you contact our Support team by phone during a time in which the problem is occurring.

    If you can provide additional information regarding your current issue including any error messages, domain names, screen shots or URL’s related to the incident this will be helpful in our review or your account and issue. Please also try to reproduce your issue through another network and Internet Service Provider.

    Please let us know if we can assist you in any other way.

    Regards,
    Eddie P.
    Online Support

    Need additional help? Please visit us at support.godaddy.com.

    ————————

    Guilherme Vaz
    6/23/2012
    6:57 am
    Dear Eddie,

    I understand that you need to see the error, but I couldn’t let the plugin active, because it messes up with my blog layout, and GoDaddy response time is way to big for me to let the blog like that. However, I’ve managed to take a screen shot of the problem.

    The error message is this one:

    Fatal error: Uncaught CurlException: 28: connect() timed out! thrown in /home/content/40/8883240/html/blog/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 825

    Hope you can help me on this one.

    Best wishes,

    Guilherme

    —————————–

    Guilherme Vaz
    6/23/2012
    7:02 am
    Here’s another image, showing how the blog is affected by the error.
    You can see that the heading, containing the logo and menu are gone, so as the sidebar.
    See the difference:

    http://azulestrelado.com.br/blog/2012/06/22/pre-jogo-de-vasco-x-cruzeiro-23-06-2012-campeonato-brasileiro/

    This is why I can’t let the blog with the error.
    Thanks!

    ———————-

    I’m still waiting for their reply.
    If you guys found out what’s the problem, post it here so we can help each other!

    Godaddy too.
    By the way, I disabled the plugin and still I sometimes read the error message.
    Please Help
    Do you think I remove the plugin tables in DB?

    It seems to me that the problem is not with the plugin. All indicates that it must be Godaddy problem.
    Have you disabled or uninstalled? I think you’re getting some sort of server cache.
    Godaddy support sucks. They don’t have a live chat support, so it lakes hours and hours for a poor reply. It seems to me that they really don’t care about this situation, because they can simply blame the plugin.
    I don’t know what to do.
    If I can’t get a solution from them or from the plugin developers, I’ll have to uninstall it and start from scratch again. This is bad..

    New reply from Godaddy. No advance on the matter.

    Go Daddy Support
    6/23/2012
    1:45 pm
    Dear Guilherme,

    Thank you for your reply.

    As I understand, you are experiencing some issues with a plugin returning an error message. Please note that we are unable to support third party application issues and we do not support the inner functionality of this program. If you are having difficulty using a third party product, we can help troubleshoot that process to the point that we find that the issue lies entirely within the configuration of that product. You may wish to consult with a community forum online or do a search on your favorite search engine as other users may have encountered a similar problem in the past and may offer helpful solutions.

    Please let us know if we can assist you in any other way.

    Sincerely,
    Daniel P.
    Online Support Team

    ————–

    Guilherme Vaz
    6/23/2012
    2:05 pm
    Hello Daniel,

    I know that Godaddy can’t support me on third part application issues. BUT I’ve been trying to isolate the problem, as I’ve created a thread on WordPress.org. Take a look here:

    http://wordpress.org/support/topic/plugin-seo-facebook-comment-uncaught-curlexception-28-connect-timed-out

    You can see that everybody who is having the same problem, have Godaddy as they host provider. I think that could be a good start for you to star checking some configurations of CURL, since that’s the exception.

    I thank you for your reply. I hope we can solve this matter together.

    Thanks.

    New message from Godaddy. They are the worse support ever.

    Go Daddy Support
    6/23/2012
    11:08 pm
    Dear Guilherme,

    Thank you for your response. I understand you are concerned about the website giving a timeout error. We have reviewed your account and could not find any issues with the hosting account. As previously stated we will not be able to assist with 3rd party application issues or the inner functions of this program. I would recommend to continue consulting with community forums or the developer of the plugin to locate solutions to the issue. I apologize for any inconvenience that this may cause you.

    Please let us know if we can assist you in any other way.

    Sincerely,
    Justin P.
    Online Support

    I think the problem lies in facebook not the host server nor the plugin. So I ask the developer of the plugin to modify it.

    Problem is with GD proxying and facebooks basecode. After a while and a bit of reading I got it fixed.

    Look here;

    http://stackoverflow.com/questions/9852937/php-curl-proxy-not-work-with-godaddy-shared-hosting

    Done.

    Thanks.

    I was having the same problem with using facebook login on a godaddy linux shared server. I solved the problem in a surprisingly simple way. I was using the url https://mywebsite.com/example.php

    THIS WORKED:

    https://www.mywebsite.com/example.php

    Turns out it was a facebook authentication thing, the url they have on file only works with the www.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Plugin: SEO Facebook Comment] Uncaught CurlException: 28: connect() timed out!’ is closed to new replies.