Support » Plugin: SendPress Newsletters » [Plugin: SendPress] Email Preview/Send/Tracking Issue

  • Resolved bamajr


    After setting up a test email, there seems to be some issues.


    After Navigating to:

    SendPress > Emails

    I’m able to preview the email, as I created it, when I press the “View” button.

    From the same navigation location (SendPress > Emails), I’m able to edit the email, when I press the “Edit” button.

    From the same navigation location (SendPress > Emails), if I press the “Send” button, It displays the 404 error page of my theme as a preview.

    From the SendPress > Emails > Send navigation location, when I press the “Send” button, It displays the 404 error page of my theme as a preview.

    If I click the “Confirm Send” button and send the email anyway, the email comes through, as it shows up after pressing the “View” button (as it should).

    I’m not sure what is supposed to show up, in the “Send” screens, but I’m sure it isn’t a preview of the 404 error page of my theme.


    All delivered emails are being delivered to the spam folders of my test email accounts.


    The tracking for “Opens” and “Clicks” seams to be working, at least partially.

    I sent the same test message to a test email account twice, under two separate send attempts. I opened the email and clicked the link, which shows up in:

    SendPress > Reports

    under both the “Opens” and “Clicks” columns.

    However, every single time I refresh the view of the email, another “Open” is tracked. If I click on the link again, another “Click” is tracked. While it may be of interest, to know how many times a single person opened an email and clicked on the link, it is far more useful to know how many of each email address, in the specified list, opened the email and clicked the link.

    For this plugin to be viable, people will want to be able to track the “Opens” and “Clicks” from each subscribed email address, independently. In other words, after an email is sent, I want to be able to go to:

    SendPress > Reports

    …Click on the email sent, and see a list of every single subscriber, that email was sent to, along with the “Opens” and “Clicks” of each subscriber. The success rate of an email campaign is how many of the entire list, opened the email (once) and clicked the included link (once).

    The only way to do this is to add some sort of hash-tag to the links, in the email, which identifies each subscribers email address, separately.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m experiencing a similar “view e-mail issue” that bamajr explains in his post, but for me it’s when I click the “view” button when I’m in the SendPress > Emails tab. The pop-up just shows a 404 error page for my theme.

    Anyone else experiencing this? Or should I try re-installing?

    Thanks in advance!

    Plugin Author itdoug


    bamajr was experiencing a 500 error as well. I’ve seen issues with certain themes. Could you try twenty ten or twenty eleven as a quick test?

    I tried both themes and it still threw the 404, so I installed it fresh again on another WordPress site with the same theme and it worked just fine. I guess an update or something caused some issues with the plugin? Who knows.

    All’s well now, though. Thanks!


    I didn’t remember I had even posted about this issue, until @jamyam1982 posted a follow up issue.

    I was having this 404 error almost two months before I started having the 500 error. Between that time, the plugin continued to work, except for this 404 issue, until I started experiencing the 500 error.

    Do you think they are related? If so, how?

    I just wanted to add an update and conclusion/solution to my issue.

    I saw another post with a user having a similar 404 error (nothing happening upon clicking “submit” on the widget sign-up form) and apparently their custom theme didn’t have the <?php wp_footer(); ?> code in the footer. So, out of curiosity, I checked the theme I was using and it wasn’t there, so I threw it in and now it all works great. Phew!



    Its great your issue was resolved, though that doesn’t solve the 404 error issue I was having, nor the issue I’m still having with the 500 error.

    My theme’s footer.php file ends this way:

    <?php wp_footer(); ?>

    So the specific wp_footer() code, which solved your problem, is already in my theme.

    Plugin Author Josh Lyford


    Hi Bamajr,

    Are you still getting the 404 error? I know that we were having an issue rendering the preview on send in some cases based on how permalinks were setup. This should be fixed and working with all premalink formats now.

    If you are still having the issue can you let me know what your permalinks look like.

    jamyam1982 & bamajr

    It seems a lot of these end up missing wp_footer(); I am going to move the script back into the header to help reduce this issue.


    @josh Lyford

    I cannot confirm nor deny this issue, any longer. The 500 error/issue I’m having, has rendered SendPress completely unusable. When SendPress is installed, the entire WordPress Admin is gone.


    This issue still has me baffled, as I’m not experiencing any issues, with any other plugins – Only SendPress… If you follow all the extensive testing, I logged (at the post listed above), you will see I’ve come to the conclusion, one of the SendPress updates, must have caused some sort of data corruption, to the main WordPress Tables.

    Plugin Author Josh Lyford


    Just posted a reply here:

    Im gong to close this thread for now.


    @josh Lyford

    I’ll check it out!

    I am experiencing this same issue. Using 2012 theme. I enabled the old “?sendpress” and it worked after that. However, there is also a conflict now where it shows the Jetpack sharing links in a standard UL at the bottom when viewed in the Send screen.

    Plugin Author Josh Lyford


    HI themizzi

    I will take a look at the Jetpack conflict and see if we can get that fix quickly.


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: SendPress] Email Preview/Send/Tracking Issue’ is closed to new replies.