Support » Plugins and Hacks » SendPress Newsletters » [Plugin: SendPress] 500 Internal Server Error

[Plugin: SendPress] 500 Internal Server Error

  • At sometime yesterday (late afternoon or early evening) I started getting blank screens, when trying to log into my WordPress Website. Upon further investigation, I was getting a 500 Internal Server Error, though not every page was actually displaying the error message.

    I started investigating the issue. Since the text of the 500 Internal Server Error suggested “More information about this error may be available in the server error log” I started with the Apache2 error log.

    On my Debian GNU/Linux Server, this log is found at:

    user@server: /var/log/apache2/error.log

    I use logrotate so each log file is changed every day, if an error is generated. I looked at the log file and found the following error:

    [Fri Aug 10 09:26:54 2012] [error] mod_fcgid: process /home/bamajr.com/fcgi-bin/php5.fcgi(15293) exit(communication error), get unexpected sig$
    PHP Warning:  Module 'gd' already loaded in Unknown on line 0
    PHP Warning:  Module 'mcrypt' already loaded in Unknown on line 0
    <br />
    <b>Deprecated</b>:  Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br />
    <br />
    <b>Deprecated</b>:  Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br />
    <br />
    <b>Deprecated</b>:  Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br />
    <br />
    <b>Deprecated</b>:  Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br />


Viewing 15 replies - 1 through 15 (of 57 total)
  • This error started yesterday, late afternoon/evening, and it occurred every time I tried to log in or access any part of the WordPress Administration Area.

    You’ll notice the error I posted, in this message, shows today’s date. My research continued today, as I tried to figure out which plugin was causing the issue. However, with the exception of today’s date/time and the number following php5.fcgi(#####), the errors are identical, for each log in attempt and for each attempt to access a WordPress Admin Page directly.

    The weird thing is, I didn’t make any changes to the WordPress installation yesterday. I did not add, remove or modify any plugins, themes, widgets, pages or posts. I simply logged in to review page-view stats, moderate a single comment (identified as spam), and to delete a user, who signed up from a known spamming IP address.

    Then, when I tried to log in again, yesterday, late afternoon/evening, I started getting this issue.

    When the issue first started, I had the following plugins installed, including SendPress:


    All the listed plugins were activated except the three QR Code Plugins. They were installed, but not active.

    Knowing this type of issue is most likely from a Plugin or Theme, I manually removed all plugins, via FTP. I first copied each plugin over to a directory on my computer. Then I deleted the plugins from the ~/public_html/wp-content/plugins directory, on the server.

    Then I started re-adding each plugin (via FTP), by copying them back to the server, from my computer. I added one plugin at a time (in alphabetical order), logged into the WordPress admin area, activated the plugin, logged out, browsed a couple pages on the website, logged in again and logged out again. I followed this process, until I came to the SendPress Plugin – and the issue started again, immediately upon activating the SendPress Plugin.

    This time, when the issue started, I only had the following plugins installed, plus SendPress:


    All the listed plugins were activated except the single QR Code Plugin. It was installed, but not active.


    Sorry my description, of the problem, is so long. I’m just trying to be thorough, so the issue can be resolved.

    I hope I’ve provided enough details, to resolve this problem. Obviously, I can’t/wont use this plugin, until the issue has been identified and fixed.

    Plugin Author Josh Lyford


    Hi bamajr,

    Could you tell me what version of PHP you are running. Looking at what you have for an error I have no idea what would cause it but I will try and replicate it on our test server.


    Hello Josh…

    Just a few moments ago, I installed the WordPress phpinfo() plugin, found at:


    I had a script running by itself, but I wanted something which was immediately available within the WordPress Administration Area.

    PHP Version: 5.3.3-7+squeeze13

    I will be happy to provide you with any additional info you need, to help resolve the problem.

    Josh, I’m pretty sure I identified all the information in my posts above, but I also outlined the problem on my blog, at: http://bamajr.com/2012/08/11/500-internal-server-error/

    I have a lot more general information in the blog post, but I don’t believe I posted anything there, I didn’t post, for you, above…

    …but it doesn’t hurt to skim the article to see.

    Plugin Author Josh Lyford


    Hi Bamajr,

    I have not been able to recreate your problem yet on our test servers but will keep looking into the issue. We just released a new version with a lot of bug fixes and updates. Would you mind giving SendPress another go? if you would prefer not to try it again on your site i can totally understand that. Thanks again for all the info you provided.


    I’d be happy to try it again. That’s one of the things I do a lot of… trying Plugins and Plugin combinations. I’ll document the process for you, too, including a snap-shot of my installed/activated plugins.

    Ok… I’m starting with the following plugins, installed/activated (some are installed but not activated):


    This isn’t much different than the information I’ve already outlined for you, above.

    After taking the screenshot (above), I went to:

    Plugins > Add New

    In the “Search” area, I typed in “SendPress” and clicked the “Search Plugins” button.

    I clicked the “Install Now” link and confirmed the installation, but did not activate it, after the installation.

    The screenshot below, is of the plugins, installed/activated, after SendPress was installed.


    No issues to this point! 😉

    Upon clicking the “Activate” link, in the Plugins Area, I’m immediately presented with the following screen:


    When I view the source of this page, there is nothing there.

    When I navigate to http://bamajr/wp-admin/ there is nothing there either, as is depicted in the following screen:


    The images are showing use of Firefox, but I also tested in Google Chrome, with the same results.

    One other point of interest (maybe) is that after the SendPress plugin is installed, the front end of my website continues to work, but the “Admin Bar” has some weird display issues. Those “Admin Bar” issues go away as soon as SendPress is removed, as well.

    Plugin Author Josh Lyford


    Hi Bamajr,

    Thanks for testing everything again. Looks like something is still not totally right. I will keep digging around in the plugin and see if i can figure out what is now causing the white screen of death for your wp-admin area.

    We should have another release soon. Would you be able to test a prerelease version after I make some more updates to the plugin?


    I’m willing to help, in just about any way I can.

    I’m curious about why this happened all of a sudden, as the SendPress plugin wasn’t causing this problem, until the last two updates.

    I know it was working, because I filed the following support issue, upon testing the plugin, initially:


    What changed between now and then?

    Does SendPress put information in the WordPress Database? Is it possible this “DATA” needs to be removed, before trying this latest SendPress release? Where is the SendPress Data stored?

    Plugin Author Josh Lyford


    Hi Bamajr,

    SendPress should update the data as it needs but it is possible we missed something. The data is stored in the following tables:


    It also uses 3 custom post types:


    If it is a data issue then it is most likely something to do with the custom tables.

    Also in response to your other issue. The reports currently only show non-unique opens so we count every action taken. We are working on the ability to view the details and update the reports overview to show unique and non-unique opens/clicks.


    @josh Lyford

    Okay, I may be getting somewhere on this. When the issue first occurred, it was immediately after SendPress was updated (not this last time, but the time before). I had to manually remove the plugin, to restore functionality to my website’s admin area.

    Even though, I re-installed and re-activated the plugin, in an effort to test the next two updates, I was never able to delete the plugin, from the plugins area. So, obviously, the tables were never removed.

    I found:


    …which had not be deleted, when the plugin was removed.

    Can these tables simply be dropped from the database?

    I haven’t located the custom post types, in the database yet.

    Plugin Author itdoug


    Sendpress will add the tables back if removed but if you have any data you should back it up before deleting it. But if it never worked, it’s safe to drop the tables.

Viewing 15 replies - 1 through 15 (of 57 total)
  • The topic ‘[Plugin: SendPress] 500 Internal Server Error’ is closed to new replies.