WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Secure HTML5 Video Player] Problems and suggestions

[Plugin: Secure HTML5 Video Player] Problems and suggestions

  • Problems:
    The form of the video directory does not work, because it always take the root of the web page, not the directory where the videos are, and to show a video I have to put the entire address in the code: [video mp4="http://.../videos/xxxxxxx.mp4"], or this another way: [video mp4="wp-content/uploads/videos/xxxxxxx.mp4"]. This happens to me on the internet and on localhost.

    Another thing. The player (skin “tube” for example) is shown differently in each browser, and it seems that only looks good in Internet Explorer. I’ve attached a photo to see it. In Chrome the time bar moves a lot to the right. Also, in Firefox the video is enlarged, while Chrome and Explorer looks good (with black bars on the sides, not altering the appearance).

    The image: http://img17.imageshack.us/img17/3294/sameformatsdifferentapp.jpg

    Suggestions:
    It would be interesting to put a button to add a video in the form of new entry. So we should not write the code.

    It would be interesting too, to add a preview image on each video.

    It’s all by now. I’m spanish, so sorry if you don’t undestand me.

    Thansk!

    http://wordpress.org/extend/plugins/secure-html5-video-player/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Ah, I’ve seen that the extra-large control in Chrome only happends using my theme. But still a problem of the plugin, because the control should never be wider than the video.

    Here is how to get preview images. Create your video file in either .ogv or .mp4 and make a copy in the other format. Then capture a screen from the video in .png format. Then name all the files the same, but using the different extensions:

    my_video.mp4
    my_video.ogv
    my_video.png

    Upload to your videos directory and call it with the short tag:

    [video file="my_video"]

    Once I did this with our videos, everything started working.

    jinsookang
    Member

    @jinsookang

    The form of the video directory does not work, because it always take the root of the web page, not the directory where the videos are, and to show a video I have to put the entire address in the code: [video mp4="http://.../videos/xxxxxxx.mp4"], or this another way: [video mp4="wp-content/uploads/videos/xxxxxxx.mp4"]. This happens to me on the internet and on localhost.

    Could you show me how your setting for the plugin look like? It should properly be loading from the video directory provided that the directory is set in the plugin options and that it exists in the file system. Then you need only set the file name of the file, not any path.

    jinsookang
    Member

    @jinsookang

    Also, to resolve the sizing issues for the player, you may have to set the short code width and height attributes for your video, or reset the setting values in the plugin options.

    jinsookang
    Member

    @jinsookang

    It would be interesting to put a button to add a video in the form of new entry. So we should not write the code.

    Thanks for the suggestions. I agree that would be a good feature.

    I’ve put 2 settings:

    http://img842.imageshack.us/img842/9714/config1a.jpg
    and
    http://img38.imageshack.us/img38/6443/config2y.jpg

    and it don’t works 🙁

    I’ve set the width value as you said…

    [video mp4="http://localhost/blog/wp-content/uploads/videos/chip_y_chop.mp4" width="640" height="480"]

    but it don’t work. I’ve still having the problems with Crome and the video in Firefox still enlarging.

    Thanks for your answers!

    jinsookang
    Member

    @jinsookang

    From your screen caps I see you use “file:///…” as the file path. That shouldn’t work. It should be just the file path as your operating system expects it. Like what you have but without the starting “file://”.

    Ph0sky
    Member

    @ph0sky

    It still not working.

    But my most urgent issue is the width on Chrome and the styles (skins). I need it working, and if we can’t find a solution, I’ll be forced to change the plugin 🙁

    paunya
    Member

    @paunya

    I’m having the same problem that Ph0sky is having with having to type in the entire path (directory exists, and is set up in the settings). However, the main problem I have is that while the sound works, the video does not display. I’ve played my mp4 in quicktime on my computer and it all works fine, so it’s not an issue with the video itself.

    Here’s the link to the site: (video is half-way down the page).
    http://www.descaid.com/

    The shortcode looks like this:

    [video mp4="http://www.descaid.com/videos/083111DescaidMPEG4.mp4"]

    The setting for the source path is:

    /home4/descaidc/public_html/videos/

    I tried it with and without the / behind the videos folder. I tried just using the file name in the short code. I tried using the file name with the extension. None of these things worked to play anything at all. I was only able to get it to play anything whatsoever by using the code above and even then it is only playing sound. I’m at a loss. Any help?

    paunya
    Member

    @paunya

    AH… see this thread for the answer!
    http://wordpress.org/support/topic/does-not-appear-to-be-working?replies=9

    Didn’t realize firefox was so persnikety with filetypes. I used FireFogg to convert the mp4 to ogv and webm formats, uploaded all of them, switched to shortcode as follows:

    [video file="083111DescaidMPEG4"]

    … and everything worked perfectly. YAY! Hopefully this answer is helpful to others with similar problems. Make sure your browser supports the file types you are uploading! Thanks for this plugin, Jinsoo Kang and Lucinda!

    Ph0sky
    Member

    @ph0sky

    2 weeks without any solution and 1 month without update the plugin. See ya!

    jinsookang
    Member

    @jinsookang

    Thank you for your interest and suggestions.

    brucehanify
    Member

    @brucehanify

    I’m always hoping the Code Folk will take the time to publish a Step A, Step B, Step C set of instructions. I’m not exactly stupid, but I am new to setting up video players in WP, and found this particular plug in to have very little practical information. The on-site video brags it up, but doesn’t break it down.

    Hey, Trillamar! Teach me how to run your plug in, I’ll teach you how to write. I have to explain abstract concepts to simple people all day. It’s a skill. You could use mine.

    Barring that, please give me the Down and Dirty on how to make this thing work. I created a videos folder at my server directory. Now what? Do I need to have a video player up and running, or does the Ever Wondrous Secure HTML5 Video Player make miraculous use of videojs?

    The Little People patiently await instruction.

    http://www.thegrailquest.com/

    Plugin Author trillamar
    Member

    @trillamar

    Hello Bruce,

    1. In your WordPress dashboard, go to Settings > Secure HTML5 Video Player and there is a space there to specify the location of the folder where your videos live.

    2. On the page or post where you want the video to appear, use a shortcode , e.g.:

    [video mp4="video_clip.mp4"]

    on that same admin page, there are examples of various shortcodes for the type of video you’re serving up.

    3. You don’t need a player. VideoJS and FlowPlayer are part of the code.

    Hope this clears things up. Good Luck.

    Lucinda

    brucehanify
    Member

    @brucehanify

    THANK YOU VERY MUCH.

    I think my path is buggers. Almost there.

    Thank you, Lucinda.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Secure HTML5 Video Player] Problems and suggestions’ is closed to new replies.