[resolved] Plugin Search Strict Standards error (10 posts)

  1. jonradio
    Posted 3 years ago #

    Version 3.6-beta4-24665

    Error message (displayed four times): "Strict Standards: Only variables should be passed by reference in C:\xampp\htdocs\wpbeta\wp-admin\includes\plugin-install.php on line 232"

    Displayed at the top of the Search Results Admin page when the Search Plugins button is pushed on the Add New Plugins admin page.

    Oddly enough, this occurred with a keyword of "jonradio" but not with other searches I tried.

    Exact URL: http://localhost/wpbeta/wp-admin/plugin-install.php?tab=search&s=jonradio&plugin-search-input=Search+Plugins

  2. I can't replicate this.

  3. Drew Jaynes
    Docs Czar
    Posted 3 years ago #

    Two questions:

    1. Can you update to RC1 and test again?
    2. What are your server specs, including PHP version?
  4. jonradio
    Posted 3 years ago #

    Just upgraded the site to RC1 and still getting the same error message.

    This is an Xampp Version 1.8.1 install
    Operating System is Windows 8 Pro, 64 bit
    Hardware is Intel dual-core processor with 4GB RAM
    php Version 5.4.7
    php memory_limit 256M
    Zend engine Version 2.4.0
    Apache Version Apache/2.4.3 (Win32)
    MySQL Version 5.5.27

    I'll try a Linux server and see what I get and report back here.

  5. jonradio
    Posted 3 years ago #

    The only Linux server I have access to does not work properly with the .htaccess php settings that I am using in Xampp. I tried to replicate them in a local php.ini file in wp-admin, but I am not getting the error above.

    On the Xampp system where the error occurs, the .htaccess in the root (WordPress is installed in the /wpbeta/ folder) includes the following:

    php_flag display_errors  On
    php_flag display_startup_errors On
    php_flag track_errors  On
    php_value error_reporting 2147483647
    php_flag html_errors  On
    php_flag session.bug_compat_42  On
    php_flag session.bug_compat_warn  On
    php_value max_execution_time 90

    WP_DEBUG is set to TRUE in wp-config.php

    I'll try a Web PI install on another computer.

  6. Drew Jaynes
    Docs Czar
    Posted 3 years ago #

    And I'm assuming you've already taken the step of deactivating all plugins and switching to a default theme?

  7. jonradio
    Posted 3 years ago #

    Thank you for asking. I deactivated all plugins, including the WordPress Beta Tester, and switched theme from Twenty Eleven to Twenty Thirteen, and the error message still is there.

  8. Drew Jaynes
    Docs Czar
    Posted 3 years ago #

    Trac ticket: https://core.trac.wordpress.org/ticket/24747

    (We mark 'resolved' in this forum once a Trac ticket has been created)

  9. Drew Jaynes
    Docs Czar
    Posted 3 years ago #

  10. jonradio
    Posted 3 years ago #

    Verified that this fix solves the problem on my original test environment where the problem was first observed.

    Thank you so much!

Topic Closed

This topic has been closed to new replies.

About this Topic