Support » Plugin: Search Engine » [Plugin: Search Engine] Not searching/indexing Pods CMS content

  • Resolved databell96


    I just installed Search Engine, indexed my site, which is all PodsCMS based and none of that content indexed at all. I tried a few searches to no avail. I turned off my plugins except for Pods CMS and SE and nothing changed. Is there an issue with SE and Pods?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Scott Kingsley Clark


    Can you post the URL to your site and / or send me example HTML of what your Pod Pages look like? Search Engine indexes like Google, so it picks up links wherever they are on the page and moves onto the next. Do you get ANY results when you search? Check your wp_search_engine_links table and see if you see any of your Pod Page URLs there.

    Scott, the site is private. It’s not for the general public. In fact, I’m about to password protect it for that reason. If you provide me with your email, I can send you a link.

    That being said, I’m not any results for anything. But then again, all content is in the Pods. I’m looking at wp_search_engine_links and there are no Pod URL’s listed.

    Plugin Author Scott Kingsley Clark


    Try scott (@) skcdev (.) com

    Hi Scott,

    I have implemented the pods CMS into my clients WordPress website, and i’m having the same problem with content not being indexed, my wordpress installation is in a directory – will this have an affect on the search engine when indexing?

    I’ve tried both: and when indexing, but still no joy! The seemed to index successfully, but no results; and the threw up an invalid url error when indexing!

    My “wp_search_engine_links” contains:
    SELECT * FROM tasty_searchengine_links WHERE 1

    Any help would be much appreciated!

    Plugin Author Scott Kingsley Clark


    Simon, can you send details about your site for me to help you figure out what might be going on here?

    Plugin Author Scott Kingsley Clark


    (My e-mail is posted above)

    I have the same problem with content not being indexed.

    The sites I run internally work fine but on my host the pages won’t cache.


    Plugin Author Scott Kingsley Clark


    Try checking the latest release, it should solve your issues.

    Hi Scott, getting mixed results with the new version. Better results than before so I’m thinking it may be more my understanding of how the process works rather than issues with the plugin.

    I have a product catalogue that is several layers deep. It appears to index some products and not others. (Pages: Range, Category, Product, Product Details. Each product belongs to a category, each category belongs to a range.)

    Also I like to know how can I manage the display of index results, eg meta description, title, etc.

    Is there somewhere you can point me, eg a knowledge base or document that outlines how the engine indexes and if the way I construct the page / code, etc makes an impact? I use templates rather than pods pages as a general rule. Does this matter? Happy to dig around and find answers, just not sure where to start.

    I can send you a link of the site if you want to see what I mean by mixed results.

    Appreciate your help as always.

    Plugin Author Scott Kingsley Clark


    Sure, send along the link to your site. If you want it to be private, contact me through any of the various ways shown on my site

    Search Engine uses some standard indexing practices. It picks up your Meta ‘description’ tag if you have it set for a page, and uses it for the page’s description in the results. It also follows robots-related rules, so any Meta ‘robots’ tags or rel=”nofollow”/rel=”noindex” are also followed. There’s an option to disable that in the advanced indexing settings on the Wizard. If you’re looking to include/exclude content specifically from the indexing process, look at the Search Engine FAQ found at – – for details on classes you can use in your templates to fine tune what gets into your index.

    If you’re having some issues getting your pages indexed, you’re likely having issues getting your pages indexed on some real search engines. If you notice any specific cases you believe to be the result of a bug, send the links in question and the terms you’re searching for and I’ll run spider it from my test site and test myself. If I can confirm the bug, I will fix it on my end, otherwise I’ll provide you with some details on how you can fix it on yours.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Search Engine] Not searching/indexing Pods CMS content’ is closed to new replies.