Search and Replace
[resolved] Sufficient Permissions Error (6 posts)

  1. Mystech
    Posted 3 years ago #

    Does not work, generates the sufficient permission error page. Updating does not resolve, neither does deactivating other plugins and using default theme.


  2. jacksonmurphy
    Posted 3 years ago #

    Same problem here...

  3. Frank Bueltge
    Plugin Author

    Posted 3 years ago #

    wich wordpress version?

  4. Daiv Mowbray
    Posted 3 years ago #

    Same problem here,

    You do not have sufficient permissions to edit plugins for this blog.

    WP Version 3.3.1
    S&R Version 2.6.3

    Disconnected all plugins and receive the same response.
    Tested on second server, different domain, same result.

    checked the current_user_can function in the codex.
    seams that there has been a change in parameters for the function.
    what is in the plugin code is:
    if ( current_user_can('edit_plugins') )

    All works as expected when changed to:
    if ( current_user_can('administrator') )

    That's on line 792 of the plugin php file and on line 99.


  5. Frank Bueltge
    Plugin Author

    Posted 3 years ago #

    but the object edit_plugins is an default object since WordPress 2.0; see http://codex.wordpress.org/Roles_and_Capabilities#edit_plugins

  6. sabahat
    Posted 2 years ago #

    Thank you, Daiv Mowbray. Your solution worked for me!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic