Support » Plugin: Scissors Continued » [Plugin: Scissors Continued] edCanvas is not defined

  • getting a javascript error ‘edCanvas is not defined’ in wp-admin/load-scripts.php in function send_to_editor on the last line.
    Pity!

Viewing 2 replies - 1 through 2 (of 2 total)
  • likely the plugin developer needs to add a javascript hook kind of like the below.

    Replacing ‘group-desc’ with which ever text area ID it is.

    function add_edCanvas() {
    echo ‘<script type=”text/javascript”>
    jQuery(document).ready(function(){
    edCanvas = document.getElementById(“group-desc”); });
    </script>
    ‘;
    }
    add_action(‘wp_head’, ‘add_edCanvas’);

    Ugh, WP’s integration of this is truly bad. This fails if your plugin uses 2 (or more) TinyMCE instances.

    This is the best reference I’ve found for this, but it’s still incomplete for some scenarios:
    http://dannyvankooten.com/450/tinymce-wysiwyg-editor-in-wordpress-plugin/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Scissors Continued] edCanvas is not defined’ is closed to new replies.