WordPress.org

Support

Support » Plugins and Hacks » Sabre » [Plugin: Sabre] No matter what i configure, people can't register

[Plugin: Sabre] No matter what i configure, people can't register

Viewing 14 replies - 1 through 14 (of 14 total)
  • THe MySQL tables aren’t even added…

    *sigh*

    Yes it’s a clean install and i’ve tried to re-activate.

    I’m having the same problem. I had it installed on other sites and it worked fine, however I had to uninstall it after the WP upgrade on one site, it refused to work, and now on this new site, clean install, I get the same errors as above.

    Apparently it works if you install 1.2.2 and run the query manually.

    So, this means the installation script is broken!
    After manually adding the table to MySQL the plugin seems to work fine!

    Run this query in PHPMyAdmin using the SQL field to add the table:

    CREATE TABLE wp_sabre_table (
      id bigint(20) NOT NULL auto_increment,
      user_id bigint(20) NOT NULL default '-1',
      user tinytext,
      email varchar(100) default NULL,
      user_IP varchar(100) NOT NULL,
      first_mod datetime NOT NULL default '0000-00-00 00:00:00',
      last_mod datetime NOT NULL default '0000-00-00 00:00:00',
      msg text,
      status enum('ok','ko','pending','to confirm') NOT NULL default 'pending',
      captcha varchar(100) default NULL,
      md5_id varchar(50) default NULL,
      math smallint(6) default NULL,
      invite varchar(50) default NULL,
      letter char(1) default NULL,
      PRIMARY KEY  (id),
      KEY last_mod (last_mod),
      KEY md5_id (md5_id),
      KEY user_id (user_id)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8;

    Use at your own risk!

    Thanks for you suggested fix. I decided to uninstall it however and looking at other options. Simple:press forums, created for wordpress, had a GREAT captcha drag n drop system, that extended to the whole WordPress site, but they started charging for their plugin so I stopped using them.
    I’ll just keep looking. :/

    Captcha is crap though… The stealth option in sabre is much much better. Even the math question is friendlier.
    Figuring out distorted images only disturbs users and drives them away.

    It’s a drag n drop though, called captcha but not quite. It tells you to drag a certain image and drop it into the circle. I had no registration issues at all while using it.

    I see 🙂 Even so, it requires an interaction from the user.. i believe that should not be necessary.
    But the drag and drop thing you describe sounds better than a actual captcha ..

    I hate captcha. Some sites have ridiculously complicated captcha – I prefer a simple text question ‘fourth letter in the word applesauce’ or no interaction whatsoever.
    Sites that I have used captcha on have not at all been safe from spammers.

    haha and yet you use it 😉
    but i agree, they don’t do much good in protecting a site.

    No actually. I do not use it – because it did not keep them safe from bots, as I mentioned above. I simply have my wp portion of the site closed to new registrations right now and am activating them manually. The forum parts of my sites use SMF and they have a math/text question.

    Hi Arnan-
    Thanks for your suggestion to add the table manually to the database. I was having the same issue when I tried to register as you – variations of:

    ERROR: Unknown session.
    ERROR: Invalid session status.
    ERROR: Registration stopped by Sabre.

    I added copied your code and added the table to the database and voila, users can register.

    SABRE 1.2.2 and WP 3.4.2

    If it takes the author this long to fix the issue you shouldn’t use the plugin.
    Clearly he doesn’t care for quality OR protecting your site.

    IAmMarchHare

    @iammarchhare

    Well, this plugin looked promising, but like Arnan said, why bother? I need something that at least has a chance of being supported in the future.

    IAmMarchHare — it looked so promising that I decided it was worth fixing. I took the liberty of updating a few things in the plugin including the database error because I really wanted to use it and the developer seems to have disappeared. If he ever comes back, I’ll be happy to remove my link. Deactivate the current version of the plugin and delete it. Then upload this zip file to install the updated version… and you should be back online.

    sabre-1.2.2.2.zip

    I’ve updated it a couple times for various things, so I just tacked another .2 onto the end of the version number.

    I’ve fixed the MySQL table creation error by removing the deprecated TYPE option.

    I’ve also fixed the DNS blacklist issues. The queries worked, but they would return false positives. I replaced zen.spamhaus.org with the two correct servers: sbl.spamhaus.org and xbl.spamhaus.org.

    I also updated the gethostbyname logic to prevent false positives. It will only show the banned ip error if one of the proper DNS blacklist servers recognizes the IP address.

    I don’t have much time to maintain a plugin, but I did fix what wasn’t working for me — and what most people are complaining about on here. I cannot guarantee that I’ll be able to fix any other issues as I seldom have time to visit the forums.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Sabre] No matter what i configure, people can't register’ is closed to new replies.
Skip to toolbar