[Plugin: RSS Footer] Duplicate information is being written to my RSS feed (7 posts)

  1. asmeyers
    Posted 6 years ago #

    I've got this plugin implemented and it's writing the content I want but it's writing it twice.

    Here's my RSS link:

    You'll notice that this bit is written once at the top and once with the actual post content. And the second time all the HTML is stripped out of it:
    Read 'Selling Your Screenplay is now on Facebook' at http://www.SellingYourScreenplay.com.

    My settings are as follows.
    Here's what's in the textarea:

    <strong>Read '%%POSTLINK%%' at <a href="http://www.sellingyourscreenplay.com">http://www.SellingYourScreenplay.com</a>.</strong>

    And I have the content position set to "before".

    Any idea why it's writing it twice?

  2. asmeyers
    Posted 6 years ago #

    Here's the code in my textarea. It looks like it got cut off in my original message.

    <strong>Read '%%POSTLINK%%' at <a href="http://www.sellingyourscreenplay.com">http://www.SellingYourScreenplay.com</a>.</strong>
  3. asmeyers
    Posted 6 years ago #

    One thing I just noticed, my RSS is set to only show the "summary" and the problem goes away when I set it to show the whole post in the RSS feed. So it's something to do with that - it duplicates the RSS footer when it's set to "before" and your RSS is set to "summary only."

    I know this is a hack but I don't have time at the moment to dig in any deeper right now. I put this code in the rss-footer.php file on line 151:

    $temp_remove = strip_tags($rssfootcontent);
    $content = str_replace($temp_remove,"",$content);
  4. Joost de Valk
    Posted 6 years ago #

    Which version of the plugin are you using?

  5. LAffaire
    Posted 5 years ago #

    I have the same problem.

    WP 2.9.1
    RSS Footer 0.9.6
    Set to "Content position: before"

    Looking at the XML source of the generated feed, in the <description> field, I see the RSS footer line once fully linked followed by a line break, then once more with links stripped out, then my actual content without line break.

    I noticed people have complained about this in multiple posts here as far back as half a year ago. Are you planning to address this or should I look for an alternative solution?

  6. LAffaire
    Posted 5 years ago #

    BTW, a closer look shows that the line break mentioned above comes from the first, linked instance of the RSS-Footer text being wrapped in:
    &​lt;p&​gt; ... &​lt;/p&​gt;
    which of course evaluates to HTML p tags. The second, unlinked instance is just part of the first regular paragraph.

  7. LAffaire
    Posted 5 years ago #

    I changed my blog now to have full content feeds and now I find that the <description> section still has the duplicated RSS Footer text, but the <content> section doesn't.

    As a result, my feed looks fine in readers that show full content, but quite silly in readers that only show the <description> excerpt, e.g. MyBlogLog. In the latter, RSS Footer now takes over 2/3 of the displayed text.

    I can't work like that. Since the author doesn't respond, I'll delete RSS Footer. Found this one: http://wordpress.org/extend/plugins/copyfeed/ A bit more complex, but at least it works.

Topic Closed

This topic has been closed to new replies.

About this Topic