Support » Plugin: RomeLuv Google Maps for WordPress » [Plugin: RomeLuv Google Maps for WordPress] Google API not required anymore

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello,

    i had the same issues. Since it is open source, i created a fork and fixed the problems. You can find it here:


    Hi wpshoof,

    I’ve used your fork so that I don’t need the Google key anymore.

    Anyways the code is not working I don’t get why.. I’ve tried both the shortcode and the php code approach but still nothing. By now I have an empty space where the map should be with a acurate div with the id=”single-post-map” appering but that space is just blank and the map doesn’t load.

    Any clue on this? I’d appreciate any help.

    Here’s the example with php code:

    Hello pedroteixeira07,

    I have looked into your example and watched it closely.
    It seems that there are a lot of p and /p in the javascript code which do not belong there.

    Did you copy the javascript source code into the post?
    If so, try to delete all line feeds. WordPress tends to automatically insert p and /p tags to generate line feeds.

    Then try to select option “Place before content”.
    Just to see if it generally works.
    Post the result here.

    This will give us more information about where the bug comes from.
    I will happily hunt this bug with you.


    Hey wpshoff,

    Can’t how to thank you.

    To solve the initial issue of the plugin being out of date I’ve copy/pasted into the romeluv-google-maps-for-wordpressromeluv-maps.php file the code from RomeLuv Reowork that you mentioned on the prvious post.

    I was using a plugin to allow me to use .php on the post so maybe that explains all the p and /p tags.

    I’ve removed now the “Manual map placement via PHP code” and replaced it for the “automaticly place map BEFORE the content”.

    On the single post “Maps” entry I’ve written: Eiffel Tower, Paris. Yet, the space of the map is there – the map itself still not appearing…

    Thank you so much for your support. Hope to hear some feedback soon.


    Sorry forgot to put the link, but it’s the same as the previous one:

    Also another detail that I’m not sure if it’s relevant.
    This theme is for traveling, hence, there are some plugins related to maps. On the general settings there are this options:

    Enable Google Map
    If you want to use google map shortcode, please turn on the toggle. It will load the require scripts for integrating google map support. ON OFF

    Google Maps API Key
    Paste your Google Maps API Key here. If you don’t have one, please sign up for a Google Maps API key.

    I’m guessing for the requirement of a Google Map API Key i’s also out of date.
    Anyways I’ve tried both On and Off and the result is the same.

    Thank you very much


    Hello pedroteixeira07,

    as the options that you mention do not belong to the romeluv plugin, i do not know how they interact and why they are there.

    The Google Maps API key is not only not relevant, it will cause a problem because you cannot get a key any more. But Google will want it if you use the parameter for it.

    But back to the plugin for now. As i can clearly see there are still p s and /p s in the emitted javascript. To work around that I have committed a change to the romeluv plugin to put all code necessary into one row only. So the p and /p will not be in the javascript.

    Please update your plugin on the page and try again. Maybe its working.


    hey again,

    I’ve updated the plugin, still nothing.

    I really don’t know what to do and can’t seem to have the enough knowledge to see what you’re seeing. I’m using firefox firebug to understand the code and why is the map not working but to be honest I haven’t got a clue..


    hello pedro,

    i use “show sourcecode”. I have set the automatic line break to false. Then i look at line 110 to line 114 and i can clearly see that it is better now, since there are less linebreaks.

    To compare, look at the source code of .

    Row 110
    <p><a id="dd_start"></a> <!-- single post ...

    All javascript code and html is placed in one row of source code. No line breaks in there. While the same plugin version seems to be wrapped into 4 rows in your source code. Do you see it?

    The funny thing is: I saved your page to harddisk and deleted the few extra line feeds. And then it worked. See for yourself here:

    I wonder why you have those line feeds there.

    Do you do something special with the blog post header?
    I could try to change the source of the plugin again to remove all line feeds in the inserted content. But from what I see in the source, there should not be any line feeds.

    Since we kinda have only one message per day:
    1) Did I help you to see the problem?
    2) You can install the webdeveloper toolbar into your firefox, you will see then that it reports a javascript error because of the remaining line breaks.
    3) Now that we maybe are clear about the problem, can i delete your htm-Page on my server again :).
    And last but not least:
    If you say so, i’ll add code to remove line breaks, also i’m very sure the plugin puts no linebreaks at those places..
    Other ideas are welcome.


    hey wpshoff,

    Came here late night to make sure I’ll have 2 messages.
    First of all, thank you so much for your support, you’re doing an excellent job continuing this work by yourself.

    I’ve installed the webDeveloper Toolbar on firefox. Checked out your example, working perfectly. Im able now to spot on my code those extra line breaks you mentioned – you can delete the page on your server.

    I really have no idea what’s causing this but probably some template configuration?! This was a freebie I’ve downloaded. The weird thing is that I haven’t messed anything with the code, just really been playing with some 2 or 3 plugins.

    Maybe some javascript inserting line breaks?! Maybe some conflicting CSS issue? does it make any sense? I’m sorry I’m blank on this and I’m afraid the knowledge is quite limited.

    I have no ideas whatsoever, do you think with the code to remove the line breaks will influence on the rest of the code? Or since its only on this plugin wont interfere?


    Been playing with it.. I don’t get why is it doing this automatically, but I do have some more info on the source. It has to be the Theme I’m using. You code functions perfectly, and then I tried the live preview with the custom “twenty eleven” wordpress theme and the map is showing. So the guilty here is my “Travel Theme”.

    I’m still on it, but for now can’t think in another way besides some code to trim the linebreaks.

    Hello Pedro,

    i have uploaded another change to the plugins repository. I have inserted some code that should automatically replace line feeds with spaces. Although i believe the line breaks to be inserted after the romeluv plugin has written all its output.

    In case you need it to put it somewhere into the theme:
    $val = str_replace(array("\r\n", "\r", "\n"), ' ', $val);

    Is the travel theme still supported? Maybe you can throw this at the authors.

    and you’re welcome,

    I’ve been waiting for 4 days for their support… I guess it answers the question 🙁

    Unfortunately I have no idea where to start or how to approach this issue since I have no idea what generates these line breaks even overlapping the piece of code you gave me…

    What a pitty, I really would like to have this working

    Do you know any plugin similar to this one? That can actually place the picture itself on the maps? Thank you

    Hello and happy new year Pedro,

    mh, actually no. I have been looking for something like romeluv before I tried to fix this. I found that fixing the romeluv plugin is easier than to find another plugin that does this.
    There are tons of similar plugins out there, most of them still didn’t realize that the api has changed…

    Another thing is that unless there is something strange differently about the other plugin it will probably have the same issue with your theme.

    Dont you know someone next door maybe, that you can invite over for a beer and then you both together have a look in the theme editor? Chances are good that, given enough beer, you will stumble over the suspicious code there and be happily ever after.


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: RomeLuv Google Maps for WordPress] Google API not required anymore’ is closed to new replies.