WordPress.org

Support

Support » Plugins and Hacks » Role Scoper » [Plugin: Role Scoper] Found a bug!

[Plugin: Role Scoper] Found a bug!

  • Ok, so basically, I added the upload_files capability for contributors using a plugin like “Capability Manager”. This adds the “Upload/Insert” icons for contributors just above the post edit box when they edit posts. It works flawlessly without Role Scoper.

    When you add Role Scoper, the Upload/Insert icons seems to work at first when creating a new post as a contributor… But if you save a draft and return to it later (as the same contributor), then the Upload/Insert icons will be gone!!!

    Deactivating Role Scoper solves the problem temporarily as I haven’t really used Role Scoper yet, but I intend to use it soon.

    Can you look into this bug? I’m not familiar on how to use Role Scoper yet, so perhaps there are setting I can change in Role Scoper to fix this, or perhaps it is actually a bug.

    Thanks! And great plugin!

    http://wordpress.org/extend/plugins/role-scoper/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Kevin Behrens

    @kevinb

    You can correct this by adding the “upload_files” capability to Roles > Options > RS Role Defs > Post Contributor.

    Sorry about the cross posting. Thanks for the details!

    So why does this happen? Perhaps Rols Scoper should follow the settings established by Capability Manager (or similar plugins) unles otherwise manually configured?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Role Scoper] Found a bug!’ is closed to new replies.
Skip to toolbar