WordPress.org

Support

Support » Plugins and Hacks » Role Scoper » [Resolved] [Plugin: Role Scoper] Error message using Role scoper

[Resolved] [Plugin: Role Scoper] Error message using Role scoper

  • I have installed Rolescopper .But I am getting this error message on the “posts “page and the Rolescopper option doesn’t appear on admin menu. How can I resolve the issue?

    Role Scoper cannot operate because another plugin or theme has already declared the function “set_current_user” or forced early execution of “pluggable.php”. All posts, pages and links are currently hidden. Please remove the offending plugin, or deactivate Role Scoper to revert to blog-wide WordPress roles.

    I have deactivated many other plugins .But still the message appears.

    Update :
    wpmingle is causing the problem .Rolescopper works well If I deactivate wpmingle .

    Does anyone have Idea on resolving the issue and use the both plugins with out any problem?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Kevin Behrens

    @kevinb

    This and similar plugin conflicts are now resolved as of Role Scoper 1.3.35:

    • Compat : Don’t define pluggable function set_current_user(), to avoid conflict with other plugins that define it
    • Compat : Don’t cast global $current_user as a custom subclass, to avoid conflict with other plugins that do so

    Good to know !

    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: Role Scoper] Error message using Role scoper’ is closed to new replies.
Skip to toolbar