Robots Meta
robots.txt file - am I missing something (4 posts)

  1. bamajr
    Posted 5 years ago #

    How exactly does this plug in work with the "robots.txt" file? It does not set permissions of the "robots.txt" file, nor does it create the actual "robots.txt" file itself.

    I don't see anywhere in your directions where it says to create the "robots.txt" file, nor do I see any directions to give it.

    I assume then, this means I need to create the "robots.txt" file and place it in the root directory...

    I did that, and set permissions of CHMOD 666 & I get an error in the Robots Meta Configuration:

    Warning: fread() [function.fread]: Length parameter must be greater than 0 in /home/bamajr.com/public_html/wp-content/plugins/robots-meta/robots-meta.php on line 283

    So I tried the same steps but used permissions of CHMOD 777 & I get the same error.

    However, until the robots.txt file was created, there was no robots.txt dialog in your Robots Meta Configuration area.

    I assume this error shows that your plug-in checks for an empty "robots.txt" file. If I put information in the robots.txt file and save it, the error goes away, but none of the data related to your plug-in is added to the robots.txt file.

    Not quite sure I'm getting exactly what your plug-in does, how it does it, or how it relates to the robots.txt file.


  2. bamajr
    Posted 5 years ago #

    I tried re-installing your plug-in with a pre-created "robots.txt" file already in existence and permissions set at CHMOD 666. Your options still do not apply any changes to the robots.txt file.

    Also, when I try to uninstall your plug-in it seems to work correctly, but when I re-install the plug-in, all of the options I chose are set-exactly as they were before.

    I guess this means your plug-in rights to the database, but doesn't remove the entries from the database when it is uninstalled.

  3. bamajr
    Posted 5 years ago #

    I know other plug-ins write to the virtual "robots.txt" file in WordPress. However, if that is what your plug-in is supposed to do, it doesn't do that either.

  4. hydev
    Posted 5 years ago #

    I have the same problem - it's a useless plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic