WordPress.org

Forums

Revision Control
Possible Bug Report (7 posts)

  1. pinkdreambox
    Member
    Posted 3 years ago #

    Hi,

    After activated the plugin, the Visual toolbar in Edit Post/Page will be missing.

    So I can not set the format, align, and etc., after I deactivated Revision Control plugin, they will back to normal.

    So there might be a small conflict between this plugin and WP 3.2.1.

    Please see if this can be fixed. The plugin is really useful. Thanks.

    http://wordpress.org/extend/plugins/revision-control/

  2. Dion Hulse
    Lead Developer
    Plugin Author

    Posted 3 years ago #

    Hiya
    What browser are you using? And were any other plugins active at the time? (If its easy for you to get a list of which ones, that'd be great too)

    I've just tried the latest version of the plugin on 3.2, 3.2.1, and 3.3 (in development) and there were no issues.

    Its quite common for a Javascript error to cause the visual editor to break, since Revision Control replaces the core Revisions metabox, it might be that another plugin is breaking because Revision Control is active..

  3. pinkdreambox
    Member
    Posted 3 years ago #

    Hi,

    Thanks for the reply.

    I only have three plugins installed besides Revision Control, and I tried deactivated all of them and activate one by one. I found the conflicting plugin.

    JetPack by WordPress.com is conflicting with Revision Control, if both plugins are activated, the editing box will be gone.

    Hope this will help.

  4. Dion Hulse
    Lead Developer
    Plugin Author

    Posted 3 years ago #

    Thanks for that, unfortunately it hasn't helped narrow down the issue though, as the combination is working for me.

    What browser are you using? Do you know how to pull up the Javascript error logs?

  5. pinkdreambox
    Member
    Posted 3 years ago #

    Hi,

    Thanks again for the reply.

    I use Chrome 14, FireFox 6, Safari 5.1 on Mac, and all of them have the same problems, hope it is not Lion that is causing it.

    I tried to use Chrome's Developer tool and saw a few errors and one seems to related to after the deadline in JetPack.

    Uncaught ReferenceError: jQuery is not defined  (in wp-admin/load-scripts.php:2)
    
    Uncaught TypeError: Cannot read property 'length' of undefined (in wp-content/plugins/jetpack/modules/after-the-deadline/atd-nonvis-editor-plugin.js:1)
    
    Uncaught TypeError: Cannot read property 'length' of undefined (in wp-admin/load-scripts.php:3)

    This is all I know, hope this can help.

  6. Dion Hulse
    Lead Developer
    Plugin Author

    Posted 3 years ago #

    Thanks! That should help track it down, I'll let you know what I find!

  7. PolyWogg
    Member
    Posted 3 years ago #

    I have same problem, left you note on your website just now and then found this discussion (sorry for duplicating). This is when I go into EDIT or ADD NEW POST.

    I thought at first it was conflict with TINYMCE, but it does it with just RC as only plugin running (I deactivated the other 45).

    In my case, I'm running in Firefox 8 and IE8. Appeared to be same problem in both, but then IE8 "switched over" to visual mode after about 15 seconds. FF didn't switch, but when I reloaded the page, this time it worked.

    FWIW, I'm running Weaver as my theme (the full weaver, not simply 2010).

    If you have any thoughts, let me know...I'm thinking it's some sort of conflict with FF though -- I only recently upgraded my FF (I run it on work computer that has painful restrictions normally) and I don't think it happened before that.

    PolyWogg

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Revision Control
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic