Support » Plugin: Restrict Categories » [Plugin: Restrict Categories] restriction by role works. restriction by user does not.

  • Resolved nycgadgetgirl

    (@nycgadgetgirl)


    Problem: I’ve installed and activated Restrict Categories. Restricting based on role works great, but restricting based on username doesn’t work at all. The by user restriction is what I desperately need though. I’ve read the other forum posts and haven’t found anyone having the same problem. I must be missing something. Help?

    Environment: I just installed Restrict Categories 1.7 last night. I’m running WordPress 3.1. I don’t have any user or role management plugins installed. I was using Role Scoper up until a couple months ago, but I uninstalled it (and dropped its database tables in phpMyAdmin) after I deactivated it. I installed, tested, and uninstalled a couple of role management plugin this weekend as well, but they were uninstalled before Restrict Categories was installed.

Viewing 15 replies - 16 through 30 (of 35 total)
  • Nope, creating new roles didn’t work.

    I just used “Members” to create a new role with the Contributor defaults – read, edit posts and delete posts. I applied that role to my problem user. Restricting categories for the role works, but restricting categories for the individual user does not.

    This is the same behavior I get with the problem user when they have the default Contributor role.

    The only thing that has worked so far is creating a new user. That isn’t an option though because I have 40+ contributors on this site and they all have multiple articles. Creating new logins for all of them, reassigning all their posts and getting their profiles set up right again would be a nightmare.

    Oh, while I’m here… Here is my current plugin list. Naz and I also have Google Sitemap Generator in common. I didn’t notice that the first time I looked at his list. Here is mine:

    addthis
    admin-bar-disabler
    advanced-author-exposed
    akismet
    anywhere
    clicky
    contact-form-7
    edit-flow
    feedburner_feedsmith_plugin_2_3
    google-sitemap-generator
    members
    optimize-db
    organize-series
    query-posts
    restrict-categories
    shadowbox-js
    sitemap-generator
    spiurl
    subscribe-to-comments-reloaded
    thesis-openhook
    thumbnail-for-excerpts
    tinymce-advanced
    wordpress-popular-posts
    wp-security-scan

    PREVIOUSLY, I’ve used Role Scoper (which crapped out and stopped working properly) and Capabilities Manager, both of which have been uninstalled but may have had an effect it seems. I’ve deleted all the info for those two plugins from the database.

    I would have thought this had something to do with a user capability manager (as I had them installed before), but the installation I’m on now is a new WordPress installation and I’ve never installed any user role manager plugins on this one before.

    And I have the exact same problem as nycgadgetgirl. I have a lot of contributors and can’t just recreate their accounts. They’ve got posts and everything.

    Plugin Author Matthew Muro

    (@mmuro)

    Member

    I guess the next thing we could try is by manually restricting a category.

    If you guys can go to line 511, remove the $cat_list and type in a category ID.

    Go from $excluded = ' AND t.term_id IN (' . $cat_list . ')'; to $excluded = ' AND t.term_id IN (31)';

    This will make it so any user or role that has categories selected are restricted to a single category. If the users are restricted at this point, then I might have an idea of what’s going on. Let me know what happens here.

    When I use the category ID of the category that was missing in the array earlier, it doesn’t show up (which means the category box is completely empty).

    When I use a different category ID for a category that did show up before, it shows up.

    When I did this it restricted the “testuser” user whose restrictions work but it didn’t change anything for the “snick” user whose restrictions are not working.

    Sorry I missed this thread. I posted in another.

    It was strange, as the plugin was working initially and then went kaput out of the blue – on a site that had no changes done to it.

    It was a test site I was putting together and there were only 2 plugins installed on it. Fresh installation of latest WP.

    I’m hoping to use this plugin in conjunction with a “Bind user to category” plugin which tosses the user into a specific area by default should they not select the category.

    Looking forward to a working update. I’d be happy to toss you access to the test site if you might find it useful in any way.

    Plugin Author Matthew Muro

    (@mmuro)

    Member

    Hey everyone,

    I have been working hard on an update to the plugin which I believe will fix the problems with user restriction. There are some behind the scenes things that I’ve been working on, too, which is why I haven’t responded until now.

    Sit tight and I should have it out tomorrow (hopefully). Thanks for being so patient.

    That’s awesome Matthew! Thanks for the work you’re putting into it. 🙂

    Plugin Author Matthew Muro

    (@mmuro)

    Member

    Version 1.8 is out now. Download it and please let me know if you are still experiencing problems.

    FYI – the page says 1.8 but the update date hasn’t changed from 1/20/2011 and the update isn’t showing up in my plugin list as available for upgrade. Was able to upgrade by searching for it though. Just letting you know.

    Testing now…

    Plugin Author Matthew Muro

    (@mmuro)

    Member

    Yeah, the Last Updated thing is an issue that affects a lot of developers, not just me. :/ Supposedly, WordPress is working on fixing it, but I have no idea when it’ll be fixed.

    If the plugin doesn’t show having an update in your site yet, it’s because it checks every so often. Best way to get it immediately is to download and upload to your site.

    http://wordpress.org/extend/plugins/restrict-categories/

    IT WORKS!!!!

    Awesome work Matthew!

    (Oops! Sorry, I wrote this a half hour ago and never hit “Post.”)

    Hey! cool, downloading this afternoon and will report back on how it goes.

    Thanks so much – really looking forward to using this plugin and it is at a great time for a site I’m doing.

    Plugin Author Matthew Muro

    (@mmuro)

    Member

    Cool, glad to hear it. I’d be grateful for a vote on the compatibility box to reflect that.

    Naz, let me know if your problem has been solved and if so, I’ll go ahead and mark this as resolved.

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘[Plugin: Restrict Categories] restriction by role works. restriction by user does not.’ is closed to new replies.