WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Plugin renders 500 Server Error after WP 3.5.2 upgrade

[Resolved] Plugin renders 500 Server Error after WP 3.5.2 upgrade

  • I just recently updated to WordPress 3.5.2 and found myself with random 500 server errors when accessing the backend. It took quite a while to debug (after disabling all plugins, checking .htaccess & deactivating/uninstalling W3 Total Cache) and this is what I found…

    PHP Fatal error: Call to undefined function wp_get_current_user() in /var/www/www.MY-WEBSITE.info/htdocs/wp-includes/post.php on line 2121

    We are on a multi-server setup which might explain the random occurences of the errors. It seems the plugin tries to execute/check wp_get_current_user which isn’t loaded/available yet.

    After disabling Plugin Organizer it all worked again which leads me to believe that it is a plugin issue which started with the 3.5.2 update.

    Any info on why this happens / a workaround?
    Regards!

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    Did you try to disable and re-enable the plugin? Did you try to manually delete the mu-plugin file from the mu-plugins folder and then copy it over again from the lib directory? I’ve seen this error when the wrong mu-plugin file was in place.

    I did try disabling & re-enabling but that didn’t work. I’ll try to re-install completely over the weekend & hopefully that’ll do the trick. Will report back.

    Thanks for your support!

    Plugin Author Jeff Sterup

    @foomagoo

    Some bugs have been fixed and I think everything has been worked out in 3.0.9.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Plugin renders 500 Server Error after WP 3.5.2 upgrade’ is closed to new replies.
Skip to toolbar