WordPress.org

Support

Support » Plugins and Hacks » [Resolved] plugin removes '.' from aliases

[Resolved] plugin removes '.' from aliases

  • I have a client with an old static site that has .html extensions on all of their (SEO unfriendly) page urls, so I thought I’d use Swerve to put in the old urls as aliases when I converted their site to WordPress, but the periods ( ‘.’ ) get stripped out, resulting in a 404 Not Found. Is there a setting I can change, or can you tell me the file and line number to change to allow periods to pass through?

    Thanks in advance,
    Dean

    http://wordpress.org/plugins/swerve/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello!

    I just installed Swerve and I’m having the same issue with stripped punctuation. Upon Save, all punctuation is being removed from the alias url I type in for the Page, including “:” and “.”, rendering my alias url unusable (404 error). I’m running WP 3.7.1, but unsure which PHP version I’m running (not sure where to identify that). Can this be resovled with a patch/update?

    Thanks!
    Barry

    Plugin Author Matt Watson

    @mwtsn

    Hi Bremis and Dreeds,

    Sorry about that. We will look into this for you this week and look into making a setting for you guys.

    Plugin Author Matt Watson

    @mwtsn

    If you could both send me examples of where you have this problem that would be helpful 🙂

    I modified a line in the code to get it to work but I think the plugin has been updated since then so I don’t have the file/line number handy. I just needed it for migrating old existing pages so it’s not an issue for me now. Thanks very much for your reply. Cheers, Dean

    Hi and thanks for your response. Unfortunately, I was pressed for time and have since installed a different plugin that has addressed my needs for a simple redirect of an alias url. An example of what I was trying to do is:

    I typed in the Alias url: http://coast-santabarbara.org/sr2s
    to redirect to another url. But after clicking Save, the Swerve plugin removed the punctuation in the alias url, resulting in:

    http//coast-santabarbaraorg/sr2s

    I hope this is helpful.

    Thanks!

    Barry

    Plugin Author Matt Watson

    @mwtsn

    Thanks guys,

    Bremis, unfortunately I haven’t built in redirects to third party sites yet, but I will add it to the back log and try and get this feature introduced.

    Sorry I wasn’t about at the time dreeds, I will look at sorting this out in the next build.

    If you can think of any more features, please drop me a message.

    Matt 🙂

    Plugin Author Matt Watson

    @mwtsn

    Redirects are now added as a feature in v3.1.0

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] plugin removes '.' from aliases’ is closed to new replies.