Support » Plugin: Email Encoder - Protect Email Addresses » plugin removes document body

  • Tim Reeves

    (@tim-reeves)


    Hi @ironikus,

    I have written an own, very minimalistic theme, and in general it works fine (and yes it does call wp_head, wp_body_open, wp_footer). Only problem is, that when the email encoder (or wp mailto, the older one) is active, the page output of all pages ends with </head>. The <body> is completely missing.

    I have not seen this with any other themes – I use the plugin on quite a lot of sites with various themes. So obviously my own theme is not doing something which most of them do.

    Could you give me a heads-up? I’ve tried surfing but found nothing relevant.

    Thanks in advance!

    Tim

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Tim Reeves

    (@tim-reeves)

    To add to that: No problem if choose the option “WordPress filters”, it’s only the Full-page scan option which loses the <body>.

    Plugin Author Ironikus

    (@ironikus)

    Hey @tim-reeves – Thank you very much for reaching out about that, as well as for using our plugin.
    Since the head tag is loaded accordingly, I assume the site just breaks with a PHP error.
    To make sure if that’s the case, I suggest taking a look at the debug.log file of your website as it would give a clearer view of the issues that happened.

    In case it’s empty, another possibility could be that you also try to buffer the output (e.g using ob_start() ), which could cause similar issues.

    Feel free to share some further details about the last function that is called before the site breaks.
    Thank you already very much. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘plugin removes document body’ is closed to new replies.