s2Member Framework (Member Roles, Capabilities, Membership, PayPal Members)
[resolved] Plugin removed, s2user structure is still in WordPress (6 posts)

  1. mag07
    Posted 3 years ago #

    Hello, first, I'd like to say that you seem to have massive issue with your own website. Every page takes ages to load. It's rather discouraging, especially if you happen to be using your own plugin to run it ;)

    I was playing around with it a while ago, then uninstalled it. Just now I noticed, despite being removed, I can still see S2 members roles in my WP admin.

    How do I go about removing all traces of it from my installation?

    Thank you.


  2. gheghici
    Posted 3 years ago #

    Install the plugin again. Then go to General Options and change the settings on this option:

    Deactivation Safeguards (highly recommended)

    By default, s2Member will retain all of it's Roles, Capabilities, and your Configuration Options when/if you deactivate s2Member from the Plugins Menu in WordPress®. However, if you would like for s2Member to erase itself completely, please choose: No (upon deactivation, erase all data/options).

    Then deactivate the plugin and delete it.

    Hope this helps

  3. mag07
    Posted 3 years ago #

    Thank you:)

  4. WebSharks
    Plugin Author

    Posted 3 years ago #

    Thanks for the heads up on this thread! Yes, I'm very sorry. We had some unexpected downtime at s2Member.com last week. The issues were resolved in the hours after some lag was reported. Please see: http://status.s2member.com for further details.


    See: s2Member® » Support Policy

    Support for Products by s2Member® is available only through our Customer Support Forum. Our customer support representatives are available Monday through Friday; excluding all major holidays. Our Customer Support Forum can be accessed through your account at s2Member.com. We also have a forum for Pre-Sale Questions.

    We ask that you submit all pre-sale and/or technical support questions through the appropriate forum at s2Member.com. An s2Member® support representative will gladly address your question/concern within 24-48 hours.

  5. opalideas
    Posted 2 years ago #

    This issue seems to be a difficult one.
    We have a new theme that our web contractor wishes to use - iFeature Pro 5 - but we have had continual trouble. Following another suggestion from a year ago, I went through the process of setting the Deactivation Safeguard to No (also tried iteration with it as Yes). Clicked the button to rest the roles (in several iterations). Made sure bbPress was deactivated at various times in the cycle. Etc. We lost the ability to get in all last night because of a 406 error. Our host said,"We have disabled the Mod_Security rule that was triggering this issue." That let us back in.
    I thought I had it stabilized this morning, but S2Member has again thrown up a "You do not have permission" notice for our contractor, who has Admin privileges.
    Sorry, but how can I get rid of all traces of s2Member?

  6. healthable
    Posted 2 years ago #

    Thanks it worked

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.