WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Relevanssi – A Better Search] Title gets no boost

[Resolved] [Plugin: Relevanssi – A Better Search] Title gets no boost

  • Obviously my titles were not involved in search. When I search for a certain word or phrase, posts with the exact same word/phrase are not the top results. When I flip through the pages they appear somewhere (if it’s in their post content), but not on top of the first page. It almost seems to me, as if only post content were included in search. Could that be? How to fix that?

    http://wordpress.org/extend/plugins/relevanssi/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mikko Saari
    Participant

    @msaari

    Well, it should not happen… Try increasing the title boost to something like 500 or so, and see if that helps.

    that works! thanks! haven’t found it in the documentation. and according to the backend I thought it works between 0 and 5.

    Plugin Author Mikko Saari
    Participant

    @msaari

    Nah, 5 is just the default value, and not a very big value either.

    Taylor Lovett
    Participant

    @tlovett1

    I’m having the same problem. I have a custom post type titled “Series 60”. When I search “series 60”, it shows up on like the fourth page. I adjusted the title weight to be 100000, and it still only shows up on the second page. Help!

    Thanks

    Plugin Author Mikko Saari
    Participant

    @msaari

    What is your minimum word length for indexing? Is it the default 3? In that case the “60” simply does not matter in your search, which may explain why other posts get ahead.

    Taylor Lovett
    Participant

    @tlovett1

    That fixed the problem. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: Relevanssi – A Better Search] Title gets no boost’ is closed to new replies.