Relevanssi - A Better Search
[resolved] No search results after 3.0.4 (4 posts)

  1. anmari
    Posted 4 years ago #

    HI, after upgrade to 3.0.4 (or earlier?) any search returned with no search results.

    Tried resaving options and rebuilding index (it came back with index built pretty quickly)

    Have deactivated for now, just using default serach.

    Do not have role scoper plugin that i see mentioned elsewhere.

    I have other site with 2.9.14 which seems to be fine.


  2. anmari
    Posted 4 years ago #

    Okay, I checked the change logs and saw the note about activate/deactivate.

    Since plugin upgrade does a deactivate, activate I assumed that had been done and since settings page didn't say anything... I just tried rebuilding the index.. no go.

    So a further activate, deactivate and then index rebuild did the trick.

    I suggest that whatever you have happening on the deactivate/active, you could move to the settings page - have a check at the top of the page.

    Might save some stupid support queries :-)

    Thanks for the plugin.

  3. Mikko Saari
    Plugin Author

    Posted 4 years ago #

    That's why the note is there - the plugin upgrade deactivation/activation doesn't actually trigger the WordPress plugin activation hooks. Beats me why...

  4. cathlaura
    Posted 3 years ago #

    Thanks so much for posting this. My eyes almost fell out of my head when I saw the "Sorry, no posts matched your criteria" message. Deactivate, activate and then index rebuild worked for me too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Relevanssi - A Better Search
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.