WordPress.org

Support

Support » Plugins and Hacks » Relevanssi - A Better Search » [Plugin: Relevanssi – A Better Search] No Results After 3.0 Updates from 2.9.14

[Plugin: Relevanssi – A Better Search] No Results After 3.0 Updates from 2.9.14

  • Seems like a lot of people are having this same problem, but I’m not using the Role-Scoper plugin that seems to be one of the main causes which there is a solution for. I’ve tried selecting the rebuild index options, setting it to like 3000 documents at a time (multiple times) in order to make sure it gets everything, and it still doesn’t find anything.

    http://wordpress.org/extend/plugins/relevanssi/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mikko Saari

    @msaari

    Put your search results template to a pastebin and show it to me, please.

    Here you go, this should work: http://pastebin.com/6NHT9ePM

    Also, I’m not sure if this could be an issue or not, but our theme’s Search Results just uses a php include to call the archive.php page, which is the code you’ll see in pastebin.

    Plugin Author Mikko Saari

    @msaari

    Nothing obvious in your template.

    So, is the problem in indexing or searching? Does the State of the index in your plugin settings page show the correct numbers, or does it show 0?

    I think it’s in searching… I’m not sure. I just update the plugin and then my search results no longer show anything. The plugin’s stats still say:

    Documents in the index: 2012
    Terms in the index: 212435

    So, it looks like nothing was lost and that I shouldn’t need to index again.

    Clicking the “Continue Indexing” option seems to slow down my entire site and takes forever, sometimes it loads for like 5+ minutes and then just stops loading and stays on the Relevanssi Search Options screen with nothing but a white page, and this is when I’m trying to load just 500 at a time. I’ve done this multiple times and the last time I tried it said “Indexing Complete!” yet still nothing shows when searching.

    Plugin Author Mikko Saari

    @msaari

    If you updated from 2.x to 3.x and haven’t updated your index, then that’s the problem – you definitely must reindex after the update. Make sure you click “Build index”, because that clears the old index and starts fresh.

    If you have reindexed after the update, then you’re another victim of the mystery bug that’s troubling some people.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Relevanssi – A Better Search] No Results After 3.0 Updates from 2.9.14’ is closed to new replies.
Skip to toolbar