Relevanssi - A Better Search
Missing search results for term "r2-d2" (3 posts)

  1. technabob
    Posted 4 years ago #

    So I've got a strange one. Relevanssi seems to work great for search on my site, but one particular term which I know occurs numerous times on my site is "r2-d2", but searching for that in Relevanssi returns zero results. The default WordPress search returns 89 results, though.


    I've tried it with or without quotation marks around the query, but still no results.

    I have my minimum word length set to 3 letters in the index, so do you think that could be the problem, since "r2" and "d2" might be considered two different words because of the dash?

    Should I just decrease the minimum word length to 2 characters and reindex?


  2. Mikko Saari
    Plugin Author

    Posted 4 years ago #

    Yes, dashes are replaced with spaces in indexing, so indexing two-letter words should fix this.

  3. technabob
    Posted 4 years ago #

    Thanks, I'll give that a shot when I can take a little time to rebuild indexes. I seem to recall that it took a while the first time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Relevanssi - A Better Search
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic