WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Relevanssi – A Better Search] Custom Taxonomy not indexing

[Resolved] [Plugin: Relevanssi – A Better Search] Custom Taxonomy not indexing

  • I’ve just upgraded to Relevanssi 3.0.2 and have it mostly working like the old version. However, my custom taxonomies are not indexing. Here’s what I’ve got set up.

    I have a custom taxonomy named series that belongs to a custom post type named sermons. Here’s an example of a sermon with a series called ‘Collision’.

    I have selected to index the sermons post type, and searching for statue will show the above post as a result.

    I have added series to Custom taxonomies to index:, but searching for collision shows no results.

    What am I don’t wrong? Please help me include custom taxonomies in my search results.

    http://wordpress.org/extend/plugins/relevanssi/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Same problem here, please help
    What I also don’t understand is if it’s necessary to add every custom taxonomy for indexing
    thanks

    Hi guys, I have same problem. Seems that from Relevanssi version 3, you need to be entering «custom taxonomy IDs» in the pref page, instead of names like in version 2.9.

    The custom taxonomies have the names you give them; but I haven’t found a way to get their ID (I can get the terms’ IDs, but not the tax). I have like 18000 terms, so entering every term’s ID is not really a good option…

    So I reverted to Relevanssi 2.9. Bummer, eh?

    Can somebody propose a solution to this? Find the tax ID?

    Thanks

    Plugin Author Mikko Saari

    @msaari

    They are probably indexing just fine. I found out there’s a bug that makes the search fail. I’ll push out 3.0.3 soon, that should fix the problem.

    Giakie, you need to add custom taxonomies for indexing, because otherwise Relevanssi won’t know which custom taxonomies you want to index. I suppose there should be a simple check box system for choosing which taxonomies to index – maybe I’ll add it later.

    Elricoshow, it’s talking about the taxonomies itself, not their terms. The taxonomy ID is a word. You are definitely not expected to

    Hello Mikko

    I upgraded from 2.9.1 to 3.0.2, rebuilt the index with no change to prefs, i.e. with words for custom taxonomy IDs, and none of the custom taxonomies (or their terms) got indexed.

    Plugin Author Mikko Saari

    @msaari

    Like I said, this is a bug that will be fixed in 3.0.3.

    OK

    Fantastic! And indexing seems to be much faster with v3. Congratz and many thanks for this great plugin!

    Mikko, thanks for fixing this issue promptly. I appreciate your support as I do your plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Relevanssi – A Better Search] Custom Taxonomy not indexing’ is closed to new replies.