Support » Plugin: Relevanssi - A Better Search » [Plugin: Relevanssi – A Better Search] Custom fields to index problem (Using with WooCommerce)

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Mikko Saari

    (@msaari)

    After changing the indexing options, you should re-index the whole database. Continue Indexing doesn’t work in that case.

    Which button is that? “Build the index” ? I thought I tried that too, hmm

    I tried again and got this: Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home/pdbfinec/public_html/wp-content/plugins/relevanssi/relevanssi.php on line 542

    on the settings page –
    Documents in the index: 9779
    Highest post ID indexed: 21662

    Can you please advise?

    Plugin Author Mikko Saari

    (@msaari)

    Is that the correct amount of documents? Should you have more?

    I don’t know what counts as a ‘document’ to this plugin, but I think there should be a few more, there are 9,413 products, 319 posts, 49 pages: Total of 9781 (unless there’s something else I’m not counting).

    Anyhow, SKU custom field is not working, I tested a sample sku, and that is the most important thing I’d like to get figured out.

    What can you suggest?

    Thanks

    Plugin Author Mikko Saari

    (@msaari)

    If you keep on clicking “Continue indexing”, does it add more posts?

    I think there’s been some problems with WooThemes. Does Relevanssi actually provide your search results? Do the results change if you deactivate Relevanssi?

    Hi big problem,
    I ran “Continue indexing” as you suggested and now the website completely doesn’t work / stops responding. It just loads infinitely. Before, clearing the cache would get it to work again, but now it does not. Please advise ASAP. http://pdbhomestore.com

    Maya

    Edit: after waiting 30 mins, the site seems to be working again. Maybe it was using to much resources on the site.

    State of the Index
    Documents in the index: 9754
    Highest post ID indexed: 21662

    And it appears the index is working: http://cl.ly/H9qj
    I see terms highlighted.

    BUT SKU is not.

    Thanks

    Any idea why SKU is not working? It’s really important for us. Any suggestions?
    Thanks,
    Maya

    Also, just thought of something: by default minimum word length is set to 3, is this why SKU is not showing? Bc sku is considered 1 word?? Should I change it to 1 word?

    Thanks,
    Maya

    Plugin Author Mikko Saari

    (@msaari)

    It’s not 3 words, it’s three letters per word.

    I don’t know why it doesn’t work, if it’s a normal custom field, it should work.

    Well, sku is not working, what can we do? would you be able to go in and troubleshoot?
    I temporarily disabled relevanssi for now.
    Thanks for clarification on word length.

    Plugin Author Mikko Saari

    (@msaari)

    I do troubleshooting, but I only have time to help Relevanssi Premium customers with support licenses.

    Hi,
    I would be happy to pay the license if you could get it working.

    The issues are that the plugin doesn’t show custom fields, would cause the site to crash when indexing, and the results are poor / not accurate. So I want to make sure you’d be able to resolve each thing.

    Tried Search Everything plugin which searched sku fine, but search was slow… tried Google Custom Search which was super fast and accurate results, but half of the results had the wrong thumbnail image.

    Let me know if you can help and what is the charge.

    Thanks,
    Maya

    You actually are searching the wrong custom field. “sku” isn’t the field you want to search for “_sku” is. Albeit I am having problems getting this to work too.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Relevanssi – A Better Search] Custom fields to index problem (Using with WooCommerce)’ is closed to new replies.