WordPress.org

Support

Support » Plugins and Hacks » Related Posts Slider » [Resolved] [Plugin: Related Posts Slider] v2.0 doesn't work

[Resolved] [Plugin: Related Posts Slider] v2.0 doesn't work

Viewing 15 replies - 1 through 15 (of 18 total)
  • What versions are you trying? It does work with WP 3.2.1 and YARRP 3.4.3.

    However, it does not seem to work with WP 3.4.1, as it is triggering a “Parse error: syntax error, unexpected ‘}’ in /home1/accountname/public_html/wp-content/plugins/related-posts-slider/includes/settings.php on line 1”. Possibly a syntax or function error there.

    I have noticed that the arrows are in issue, depending on how many posts are selected for the slider.

    I’m using latest wp version 3.4.1, tried related posts slider both 1.3 and 2.0 and related posts 1.2 (latest version).

    I get good related posts, its just that they don’t have slider functionality…

    I’ve played with different posts number, and I get the same results: no arrows, posts displayed one below the other.

    Thanks for your help!

    To countermand my previous post, I now have it working with WP 3.4.1, RPS 2.0 and YARPP 3.5.2. I think the RPS install I originally had was corrupt.

    As for post numbers, try changing that in YARPP as well as RPS and see what you get, if you are using YARPP as the method for retrieving related posts.

    Also, do you have any other jQuery scripts running on your site? That could be interfering with the slider.

    There is no change if I change number of relater posts…

    I have js in my theme, but i’ve tried turning all of it and slider stil didn’t work. My domain is: presta-ecommerce.com, take a look please.

    Ok, I looked it over and there is one javascript error as shown by Firefox’s Error Console:

    Error: t.getComputedStyle(this, null) is null
    Source File: http://a.vimeocdn.com/p/1.4.25/js/player.core.opt.js
    Line: 24

    Hard to say if that could be causing any issues with the slider.

    Do you have “Related Slider Format” set to “Horizontal Carousel” in the RPS setup?

    Also, have you tried both “plain” and “default” for “Select the style for your Slider” in the RPS setup?

    Also, what is the value you have for “Posts to Scroll / Slide in one transition” in the RPS setup?

    Hello again,

    Yes, RPS is set to horizontal carousel, tried both plain and default. I’m curently running 1.3 version that probably doesnt have “posts to scroll option”. I’ve tried with 2.0 version, but I get the same results.

    How come I don’t get that error in console?

    Thanks for your help!

    V.

    Short of another plugin interfering with the slider, the only other thing I can think of is putting “clear: both” after the slider call, as it looks at first glance that a float is not being cleared.

    No luck 🙁
    I’ve tried “clear: both” before and after slider call, but I stil get the same results. I’ve also turned off that vimeo js call…

    Do you have any other idea?

    Not really.

    Maybe there is a CSS error, such as a duplicative ID or class name in both the template and the plugin CSS code. Or call to a float within the template code body that is not being cleared. Or in the footer. It really looks like that is the problem.

    Is there a way of finding out what’s exactly causing this? How do I do that?

    Thanks for your help!

    I see that you got this fixed on your site.

    I am just curious as to what the culprit was?

    I’ve changed my theme… And I’m not using your plugin, I’m using outbrain service. It was clearly problem with my theme…
    Thanks for your help!

    Actually, this is not my plugin, as I did not code it.

    However, I have offered support on it and other plugins here.

    Wow! Way to go! Thank again for your help 😉

    Not sure if this is where I need to post? I am NEW to wordpress websites. The one I am in charge of maintaining was built by a company.

    The slides on the home page no longer can be changed by use of the arrows. I am fairly sure there is a conflict somewhere, but I don’t even know where to begin to look. I’ve looked at all the plugins, but none of them sound like they would be in conflict. I don’t even know what slide program was used.

    Can anyone help? The website is http://www.stewarthome.com

    If this isn’t the right place to post, could you please let me know where?
    Thanks in advance
    Peggy

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] [Plugin: Related Posts Slider] v2.0 doesn't work’ is closed to new replies.
Skip to toolbar