Support » Plugins » [Plugin: Register Plus] register plus custom logo problems

  • Resolved conradschoice


    everything works fine except when I want to upload my custom logo (the logo is 290×200 , and i switched off “Organize my uploads into month- and year-based folders”)

    I get the following error message:
    Warning: move_uploaded_file(/usr/www/users/sacsop/sacswp//usr/www/users/sacsop/sacswp/wp-content/uploads/logoregister.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in /usr/www/users/sacsop/sacswp/wp-content/plugins/register-plus/register-plus.php on line 274

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ‘/usr/home/sacsop/.tmp/phpyOCvDl’ to ‘/usr/www/users/sacsop/sacswp//usr/www/users/sacsop/sacswp/wp-content/uploads/logoregister.jpg’ in /usr/www/users/sacsop/sacswp/wp-content/plugins/register-plus/register-plus.php on line 274

    Any help will be much appreciated

Viewing 13 replies - 1 through 13 (of 13 total)
  • sambaja


    I’m having the same problems as well. I have been using this to customize my registration form for my client sites, and they would definitely still want to see that logo in there. I tried that with one site’s that’s been upgraded from 2.8.6 to 2.9.1 — the logo just wouldn’t attach despite the instructions re the misc. It works up to 2.8.6, but beyond that version, that’s the only area with problems. I hope the plugin developers would have the time to make fixes soon. 🙂



    I’m having the same problem, running wordpress 2.9.1 at the moment.
    Any ideas?



    Bump — having exactly the same problem, also using WordPress 2.9.1. My error messages look like this:

    Warning: move_uploaded_file(/home/folder/public_html//home/folder/public_html/test/wp-content/uploads/logo-for-registration.gif) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/folder/public_html/wp-content/plugins/register-plus/register-plus.php on line 274
    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpOYHeic' to '/home/folder/public_html//home/folder/public_html/test/wp-content/uploads/logo-for-registration.gif' in /home/folder/public_html/wp-content/plugins/register-plus/register-plus.php on line 274

    Bump as well. Exact same problem



    Same problem here. The logo uploaded fine with WP 2.8.6 but now it’s broken. I am not a programmer — somebody please give us a patch or something. I’d be happy to hardwire the filename into the code if I could figure out how to do it. Thanks!



    I effing fixed it myself — and I don’t know ‘nuthin ’bout software.

    It isn’t a great fix, but it worked for me.

    1. Use FTP to upload your logo to your wp-content/uploads directory
    2. Open the register-plus.php file in an editor
    3. Find the line that says:
    $logo = $_FILES[‘regplus_logo’][‘name’];
    4. Replace that line with a line that has your actual logo file name, such as:
    $logo = ‘icon.jpg’;
    (My file name was actually icon.jpg. Make sure you put your own file name in there.)

    You’ll have to make a change to the code every time you want to use a different file name for your logo, but how often is that going to happen? I hope this works for other people as well as it worked for me. Good luck!

    You my as well disable this plugin and move on. The developers evidently abandoned it and their are some database issues that have gone ignored for months.

    We just upgraded one of our sites and I’ve reset the path to the uploads to be the default wp-content/uploads directory and unchecked organize files as per the message below the browse link. It worked this time. Using WP 2.9.2. Hope this helps. I also checked the permissions on the uploads directory.

    I finally abandoned the plugin and used login configurator which worked with no trouble at all.
    it can be found at plugin
    As you can see at my siteit worked perfectly, now I just need to figure out how to change the alternate text of the logo from the standard wordpress.
    Anyone knows let me know please 🙂

    I was having the same problem. I found the solution was to make sure the default “uploads” folder was created i.e. “wp-content/uploads”. Then putting my logo in the “uploads” folder solved the problem. As soon as I did that browsing to my logo in the register plus configuration under custom logo worked just fine.


    A simple solution is to patch the code by changing the function uploadLogo as follow:

    function UploadLogo(){
    		 	$uploads = wp_upload_dir();
    		 	$upload_dir = $uploads['basedir'];
    		 	$upload_url = $uploads['baseurl'];
    			$upload_file = trailingslashit($upload_dir) . basename($_FILES['regplus_logo']['name']);
    			//echo $upload_file;
    			if( !is_dir($upload_dir) )
    			if( move_uploaded_file($_FILES['regplus_logo']['tmp_name'], $upload_file) ){
    				chmod($upload_file, 0777);
    				$logo = $_FILES['regplus_logo']['name'];
    				return trailingslashit($upload_url) . $logo;
    				return false;

    Upload should work normally after this change.

    The bit of code left here by nschmede is the definitive answer to this issue. It works like a top and it’s clean.

    Thanks a whole bunch.

    Many thanks nschmede! That solved it. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Register Plus] register plus custom logo problems’ is closed to new replies.