Register Plus Redux
[resolved] call_user_func_array() error (13 posts)

  1. So I have a WordPress install with no plugins active except for Register Plus Redux, using TwentyTen (unmodified). I am testing this plugin, and all the options look great, but there are 3 issues:

    1) the biggest issue is that when a user clicks on "Register", they get this:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Array' was given in /home/*****/public_html/***.com/wp-includes/plugin.php on line 166

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Array' was given in /home/****/public_html/***.com/wp-includes/plugin.php on line 166

    Warning: Cannot modify header information - headers already sent by (output started at /home/****/public_html/***.com/wp-includes/plugin.php:166) in /home/richm****tl/public_html/****.com/wp-includes/pluggable.php on line 890

    I've tried to register without the plugin, and no error. I've tried the plugin with no options other than the ones that send emails to admin and the user, and I still get this message.

    2) the email that i get as an admin (using the "send as HTML" option) are sent as wierd attachments and not in the body-text of the email

    3) the email sent says the following:

    New user registered on your site

    Username: unverified_XVu1ylU
    E-mail: (private)

    that username is not very pretty, and is not what I wrote as a username.

    So what's going on here? Is it something with my server configuration??


  2. radiok
    Plugin Author

    Posted 5 years ago #

    I can't recreate 1 or 2 with 3.6.14, the version I am preparing for production, so please, give that a try. As for issue 3, while the user is in queue to be verified they get that ugly username, it's actually a random string, that way, they can't login. If we did not do that, it would be pretty difficult to build a user verification system. I could add another keyword so you could create a custom message with the desired username as opposed to the system assigned username.

    Can you give 3.6.14 a shot, and let me know what you think about the username?

  3. Hi!

    I'd love to try out .14, but I can't find the download.. I hate how WP has changed the plugin pages.. :(

    Can you point me to a zip? I looked at the blog, at the "other versions", everywhere, and I can't find it. Maybe it hasn't been approved from the plugin qeueu yet? (there is one, right?)

    As for the username, my main concern is for my client, he might be confused when he sees that. I think your suggestion of a keyword, such as %chosen_username%, would be excellent, and maybe even make it default in the message sent to the admin? :)

    BTW, I think you're doing excelent work all around.. This is the kind of functionality that should be in the Core, IMHO! :)

  4. radiok
    Plugin Author

    Posted 5 years ago #

    3.6.14 in online at WordPress now, you're right though, there's a queue the plugin has to go through before it gets posted. Well, maybe not a queue, but it definately doesn't happen immediately. Regardless, I added a new keyword %stored_user_login%, you can use that keyword to get the username as requested by the user.

    Thanks for your encouragement, maybe somebody at WordPress will have the same idea sometime! I wouldn't mind a new job!

  5. I still get the same damn error.. :(

    I'll reinstall WP, and I'll try it on another site as well, see if I can reproduce elsewhere..

  6. radiok
    Plugin Author

    Posted 5 years ago #

    Yeah, let me know, there's also some debugging code you could turn on to try and track this down. Let me know if it's an isolated issue or not.

  7. I got the same problem on another site (same server, though..)

    I'll try with a different site.

  8. So I tried it on a different server, still getting the same thing. I activated all the options I wanted, however. Not sure what else I can do..

    I tried again on the different server, but this time I only left the "moderate new users" option active 9turned off everything else).. Maybe it has something to do with the messages?

    And you know what? I'm either expericneing deja vu, or I wen tthrough the same thing with the Absolute Privacy plugin once.. let me check and get back to you.

  9. Sorry, can't find if I posted this already with Absolute Privacy. maybe it's my imagination..

    Any other ideas about how to troubleshoot this?

  10. Shrikant Joshi
    Posted 5 years ago #

    Yup! I just tested 3.6.14 creating a new user from the dashboard and I got the same message, too!

    Subject: New User Registration: %user_login%

    The rest of the message is empty but the funny thing is: All the user details are attached in a dat file called 'noname.dat'! I The message as seen on my BlackBerry give a li'l more info: it says, "Unsupported media type in header."

    I have now changed the replacement keyword to %stored_user_login% - let's hope this works!


    PS: I see you've pushed 3.6.15 - I'll check & repost if the problem continues to persist. :)

  11. Shrikant Joshi
    Posted 5 years ago #

    Okay, just checked v3.6.15 - here's the report:

    Added a user via Dashboard in WP & there's only one tiny problem so far:

    The Email subject line still says %stored_user_login% instead of the username chosen!! Neither the variable nor the actual username appears in the body! The same happens when a user tries to register using the front-end form. :(

    Also, in the list of users, unverified users appear with the "temp username" instead of the "requested username: - it's not a big deal, actually. Just reporting it. :)

    Once again, thanks for all the effort!

  12. radiok
    Plugin Author

    Posted 5 years ago #

    Your first problem is pretty simple, I don't check the subject against keywords. I'll add that in today, it's a quick easy fix. Are you still getting the jacked up emails saying unsupported media type?

  13. Shrikant Joshi
    Posted 5 years ago #

    Forgot to mention that - the 3.6.15 update contained all the data WITHIN the mail and NOT in a .dat attachment - I had meant to say that 3.6.15 had partially solved the issue.

    I upgraded to 3.6.16 but haven't gotten around to testing the update yet. Will check & post back soon, hopefully. :)

    Thanks a zillion! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic