WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Register Plus] Can’t register at all after upgrade

[Plugin: Register Plus] Can’t register at all after upgrade

  • GATEKeeper
    Member

    @gatekeeper

    After upgrading WordPress to 2.6 (and now 2.6.2) I’m completely unable to register anyone. I have disabled and re-enabled Register Plus and still get the following issues:

    In the WP Admin area, all the fields are empty for someone I try to register.

    If I go to the wp_users table, the created user has NULL in the ID field and NULL under user_activation_key and user_status.

    Can anyone tell me how to fix this, or failing that, how to remove Register Plus so I can at least register some people?

Viewing 5 replies - 1 through 5 (of 5 total)
  • whooami
    Member

    @whooami

    how to remove Register Plus …

    deactivate it. delete the files.(????!!!!)

    GATEKeeper
    Member

    @gatekeeper

    As I said, deactivation doesn’t help. It still won’t let me register – with or without the plugin active I get the NULL fields. Is it possible it’s inserted fields in my wp_users table?

    whooami
    Member

    @whooami

    As I said …

    actually, you didnt say that, but thats neither here nor there.

    Is it possible …

    you wont know until you look. though what you describe above are all fields that are there by default.

    GATEKeeper
    Member

    @gatekeeper

    Perhaps this isn’t to do with Register Plus, then. I’ve deactivated all plugins and deleted RP, but still getting the errors.

    When I tried a second time in a row to create a user, I got this error:

    Fatal error: Cannot access empty property in /home/newsblog/public_html/wp-includes/user.php on line 316

    Which is:
    $user->{$meta->meta_key} = $value;

    From:

    if ( $metavalues ) {
    		foreach ( $metavalues as $meta ) {
    			$value = maybe_unserialize($meta->meta_value);
    			$user->{$meta->meta_key} = $value;
    		}
    	}

    Did you delete the Register Plus database rows in wp_options? Maybe that would help? I believe they are register_plus and register_plus_custom. I had problems with the plugin and that helped me to reset it. Of course, it will wipe ALL of your settings.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Register Plus] Can’t register at all after upgrade’ is closed to new replies.