Regenerate Thumbnails
Unknown Failure Reason (6 posts)

  1. cozbaldwin
    Posted 4 years ago #

    Would it make a difference if the media was previously generated by timthumb?
    I've copied the upload directories to a new server and I'm using a new theme now that I believe does NOT use Timthumb. That's what's active now -- and other people have successfully used your plugin with that theme.

    Unfortunately, at the moment of typing this, I have a maintenance redirect up to block all IP's but my own so I cannot link you to it. Just wanna know if the previous theme which used timthumb could cause a Unknown Failure Reason error now?



  2. Alex Mills (Viper007Bond)
    Plugin Author

    Posted 3 years ago #

    TimThumb works 100% independently of WordPress. It takes an image URL and then creates a thumbnail of that image, storing it off in it's own cache folder.

    As long as the images were uploaded though WordPress and not via FTP or something, then it will work fine with my plugin. TimThumb never comes into the equation.

    Unknown failure reason. gets outputted when the meta data about the uploaded image is empty. That means WordPress is not storing the path to the original image file or other things like what thumbnail sizes are available. The former is the important part and required by my plugin (it needs the path so it can open it up).

  3. k1dcoder
    Posted 3 years ago #


    So how would one fix this problem. I'm running into the same problem, but I'm in a bit of a dilemna. I have 5000 images uploaded. 2,200 were successful, but then the rest all start failing wih the above "Unknown Failure Reason". I uploaded through wordpress too.

    I've changed servers a couple times, so maybe that could of had something to do with it.

    Is there any suggestion you advise to fix 3000 images worth of failures?

  4. cozbaldwin
    Posted 3 years ago #

    Pardon my poor etiquette, but in an effort to help out a fellow wordpresser, I should tell you I solved my problem by using a different plugin. AJAX Thumbnail Rebuild By junkcoder

  5. k1dcoder
    Posted 3 years ago #

    cozbaldwin, I'm currently using Thesis 1.8.4

    I commented out line 184 (read this in the comments)

    @Ljuba – I had the same issue, or so I think. Kept saying “No attachments found.” I commented out line 184 in wp-content/plugins/ajax-thumbnail-rebuild/ajax-thumbnail-rebuild.php. I don’t know if its the theme I’m using or what, but it does not like the post_parent = null setting.

    $attachments =& get_children( array(
    ‘post_type’ => ‘attachment’,
    ‘post_mime_type’ => ‘image’,
    ‘numberposts’ => -1,
    ‘post_status’ => null,
    //’post_parent’ => null, // any parent
    ‘output’ => ‘object’,
    ) );

    So it started working, but it only reads that I have 110 images, I have over 5,000+ images o_O? By any chance do you know how to fix this?

  6. cozbaldwin
    Posted 3 years ago #

    Im sorry, I can't. It's been months since I used it and can't remember if I ran into any issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Regenerate Thumbnails
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic