Support » Plugins » [Plugin: Regenerate Thumbnails] Stopped working, error msg

  • Regenerate thumbnails was working perfectly for me, but without any reason that I can find, it just stopped. I’ve added no more plugins, functions, etc., just stopped one night and started the next. I’ve been doing it in batches through the dropdown menu in the Media section

    The error I keep getting now is:

    (ID 1493) failed to resize. The error message was: The originally uploaded image file cannot be found at...

    Any idea what’s going on?

Viewing 15 replies - 1 through 15 (of 18 total)
  • I’m still getting

    Debugging Information
    Total Images: 1
    Images Resized: 0
    Resize Failures: 1
    "dsc_1565" (ID 1359) failed to resize. The error message was: The originally uploaded image file cannot be found at /home/shane/public_html/wp-content/uploads/2008/12/dsc_1565.jpg

    for images from 02/2009 and older. Every one back to that point worked perfectly. Any idea what the issue may be?

    Does /wp-content/uploads/2008/12/dsc_1565.jpg exist?

    Yessir. I’ve tried it on many others past that and none work. Anything newer (uploaded after that point) work just fine.

    Are you any good with PHP? If so, are you willing to help me debug?

    I’m curious what the output of var_dump( get_attached_file( 1359 ) ) is.

    I wish I could say I was good with it. If it’s something fairly simple that you could walk me through, I’d be more than willing to do it. Or, if it’s something that’s not so easy, I’d be up for giving you access to debug it. Just let me know

    Try adding this to the top of your theme’s functions.php file:

    add_action( 'admin_init', 'viper_debug' );
    function viper_debug() {
    var_dump( get_attached_file( 1359 ) );

    Then visit your admin area, copy/paste the little bit of output (if it’s showing your admin area, then it’s not working), and then remove the code to get your admin area back.

    Here’s the output

    string(63) "/home/shane/public_html/wp-content/uploads/2008/12/dsc_1565.jpg"

    Alex Mills


    Okay, so that’s working correctly. Looking back to the error message that’s rather obvious though. Whoops. *facepalm*

    Did you change hosting at some point or anything? I’m thinking that perhaps the absolute path isn’t correct.

    Try this:

    add_action( 'admin_init', 'viper_debug' );
    function viper_debug() {
    var_dump( __FILE__ );


    I have changed hosting before, but as far as I can remember, it was before the month & year that get this error.

    This new code gives me:

    string(70) "/home/shanehol/public_html/wp-content/themes/shaneholden/functions.php"

    I appreciate your time!

    Hi Alex, just wanted to check and see if you’ve had a chance or had any luck with this?

    Thanks so much!

    have exact same issue !


    Having *exactly* the same issue after upgrading to WP 3.4 last night on one of my mission-critical sites!

    Thumbnails mysteriously vanished on many of my posts and pages (and all galleries are pretty much broken) and regenerating them causes errors to begin at image 204 out of 2000+.

    Didn’t change hosting. Didn’t add plugins. Stumped.

    Hi Alex, I have the exact problem. I’m not sure it’s because of WP 3.4 (I don’t remember when this problem happened). Maybe it’s the problem of WP itself.

    Here’s a screenshot of an image in the Media Library that shows the error as well:

    I’m having the same issue with media thumbnails, but I’m doubtful it’s related to the plugin. Since updating to WP3.4 most of my older media is not showing up and trying this plugin results in the same error as above.

    I’m guessing something changed from the database retrieval. If you need any help debugging, I’d be happy to help!

    I’d like to add that I just just tried the above var_dump command on specific attachments and the images that disappeared return a blank string.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Regenerate Thumbnails] Stopped working, error msg’ is closed to new replies.